Bug 3818 - No relative acpi object, but need support (fan not work.)
No relative acpi object, but need support (fan not work.)
Status: REJECTED UNREPRODUCIBLE
Product: ACPI
Classification: Unclassified
Component: Power-Fan
i386 Linux
: P2 high
Assigned To: Luming Yu
:
: 3827 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-26 03:53 UTC by Oleksij Rempel (fishor)
Modified: 2007-02-01 00:21 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.11-rc1-mm1 , mm2
Tree: Mainline
Regression: ---


Attachments
dsdt samsung nv5000 (19.62 KB, application/octet-stream)
2004-12-15 00:13 UTC, Oleksij Rempel (fishor)
Details

Description Oleksij Rempel (fishor) 2004-11-26 03:53:05 UTC
Distribution:Debian Sarge 
Laptop: samsung nv5000 
I think dsdt don't realy prowide fan rules. With windowsxp fan working without 
any aditional software but with kernel 2.6.9 it dusn't working , i  
tryd patch prowidet by Luming 
( http://bugzilla.kernel.org/attachment.cgi?id=4124&action=view ) it's didn't  
realy worked but it brout the fun working without stop ....  it worked some  
hauw. With out it this laptop going to deade  
Thanks 
Alex
Comment 1 Luming Yu 2004-12-14 20:14:24 UTC
If there is No fan rules, the fan is still possbile to be controlled implicitly
by other AML method. Otherwise, ACPI is fully exempted from this issue.
You need to customize DSDT to figure out which methods could be related to FAN. 

Maybe there are some potential ACPI interpreter bug causing this issue. Don't
know so far. Could you spot it for me?
Comment 2 Oleksij Rempel (fishor) 2004-12-15 00:13:10 UTC
Created attachment 4266 [details]
dsdt samsung nv5000
Comment 3 Oleksij Rempel (fishor) 2005-01-17 12:34:06 UTC
Some think strang happened with new kernel. Alone fan not working and i wrote 
driver for i2c chip max1619 to set some ruls for it. It worked with older 2.6.x 
and now it working too, but with kerenl 2.6.11-rc1-mm1 fun start but wen it's 
cold can't stop. 
Comment 4 Oleksij Rempel (fishor) 2005-01-18 01:26:03 UTC
I made some tests with fan (for monitoring i used lm-sensors, no ruls seted): 
--------kernel 2.6.11-rc1-mm1----cold start!!!--fan not working and mus not 
max1619-i2c-0-4d 
Adapter: SMBus PIIX4 adapter at 2180 
M/B Temp: 42.00 (temp1) 
CPU Temp: 42.00 (temp2) 
temp2_min: -55.00 (temp2_min) 
temp2_max: 55.00 (temp2_max) 
temp2_crit: 100.00 (temp2_crit) 
temp2_hyst: 95.00 (temp2_hyst) 
alarms: 2.00 (alarms) 
--------kernel 2.6.11-rc1-mm1----cold start!!!--fan not working but must to!!! 
max1619-i2c-0-4d 
Adapter: SMBus PIIX4 adapter at 2180 
M/B Temp: 48.00 (temp1) 
CPU Temp: 61.00 (temp2) 
temp2_min: -55.00 (temp2_min) 
temp2_max: 55.00 (temp2_max) 
temp2_crit: 100.00 (temp2_crit) 
temp2_hyst: 95.00 (temp2_hyst) 
alarms: 18.00 (alarms) 
------------------------------------------------------------------------------ 
--kernel 2.6.11-rc1-mm1----hot start!!!(i made "make bzImage && restart")--fan 
working and must!!! 
max1619-i2c-0-4d 
Adapter: SMBus PIIX4 adapter at 2180 
M/B Temp: 50.00 (temp1) 
CPU Temp: 60.00 (temp2) 
temp2_min: 50.00 (temp2_min) 
temp2_max: 80.00 (temp2_max) 
temp2_crit: 100.00 (temp2_crit) 
temp2_hyst: 95.00 (temp2_hyst) 
alarms: 138.00 (alarms) 
--kernel 2.6.11-rc1-mm1----continue--fan still working ewen if CPU is cold!!! 
max1619-i2c-0-4d 
Adapter: SMBus PIIX4 adapter at 2180 
M/B Temp: 43.00 (temp1) 
CPU Temp: 44.00 (temp2) 
temp2_min: 50.00 (temp2_min) 
temp2_max: 80.00 (temp2_max) 
temp2_crit: 100.00 (temp2_crit) 
temp2_hyst: 95.00 (temp2_hyst) 
alarms: 10.00 (alarms) 
 
-------------------------------------kernel 2.6.10-mm3----------------------- 
---cold start--- fan not working its OK!!! 
max1619-i2c-0-4d 
Adapter: SMBus PIIX4 adapter at 2180 
M/B Temp: 48.00 (temp1) 
CPU Temp: 46.00 (temp2) 
temp2_min: -55.00 (temp2_min) 
temp2_max: 55.00 (temp2_max) 
temp2_crit: 100.00 (temp2_crit) 
temp2_hyst: 95.00 (temp2_hyst) 
alarms: 2.00 (alarms) 
-------------conitue-----make bzImage----CPU hot and fan working!!!! Yesss 
max1619-i2c-0-4d 
Adapter: SMBus PIIX4 adapter at 2180 
M/B Temp: 48.00 (temp1) 
CPU Temp: 56.00 (temp2) 
temp2_min: 50.00 (temp2_min) 
temp2_max: 80.00 (temp2_max) 
temp2_crit: 100.00 (temp2_crit) 
temp2_hyst: 95.00 (temp2_hyst) 
alarms: 2.00 (alarms) 
------------continue----CPU agein cold------------fan not working.OK!!! 
max1619-i2c-0-4d 
Adapter: SMBus PIIX4 adapter at 2180 
M/B Temp: 48.00 (temp1) 
CPU Temp: 44.00 (temp2) 
temp2_min: -55.00 (temp2_min) 
temp2_max: 55.00 (temp2_max) 
temp2_crit: 100.00 (temp2_crit) 
temp2_hyst: 95.00 (temp2_hyst) 
alarms: 2.00 (alarms) 
 
Comment 5 Oleksij Rempel (fishor) 2005-01-18 01:30:00 UTC
with kernel 2.6.10-mm3 it's can make what 2.6.x or windows can't. Yes! Yes! 
Yesss!!! I'm happy. 
Thenk you wery mathc. 
But tis is not in stabil tree. 
Comment 6 Oleksij Rempel (fishor) 2005-01-22 02:12:39 UTC
Now i know my mistake. Some times i started linux after win. I think win 
konfyusd EC ruls and linux take it. If linux start therst then ewery think OK 
and fan working. If after windows - don't. 
Comment 7 Oleksij Rempel (fishor) 2005-06-11 00:28:29 UTC
kernel 2.6.12-rc6. tested fun not working  
Comment 8 Luming Yu 2005-09-15 01:47:20 UTC
*** Bug 3827 has been marked as a duplicate of this bug. ***
Comment 9 Oleksij Rempel (fishor) 2007-02-01 00:21:54 UTC
i don't have this hardware anymore.

Note You need to log in before you can comment on or make changes to this bug.