Bug 38132 - [Warning] 2.6.39.x latencytop
[Warning] 2.6.39.x latencytop
Status: CLOSED DOCUMENTED
Product: Drivers
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: drivers_other
:
: 37652 (view as bug list)
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-06-23 18:27 UTC by Maciej Rutecki
Modified: 2011-07-10 12:41 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.39
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-06-23 18:27:35 UTC
Subject    : [OOPS] 2.6.39.x latencytop
Submitter  : Andrew Watts <akwatts@ymail.com>
Date       : 2011-06-14 17:07
Message-ID : 80098.5633.qm@web111013.mail.gq1.yahoo.com
References : http://marc.info/?l=linux-kernel&m=130807128506490&w=2

This entry is being used for tracking a regression from 2.6.38. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Florian Mickler 2011-06-26 14:09:08 UTC
This is't an OOPS, it is a WARNING... 

As far as I see, the corresponding code looks like:

     WARN_ONCE(1, "tracing_enabled is deprecated. Use tracing_on");

Does this indeed turn up in your dmesg? 

latencytop should probably do a s/\btracing_enabled\b/tracing_on/ in it's fsync.c file.
Comment 2 akwatts 2011-06-27 15:49:21 UTC
It is indeed a warning not an oops. I get it in my syslog logfile which means it is kernel.warn or higher.

Please note the separately-filed bug report at (bug #37652) as well as Steven Rostedt's comments.
Comment 3 Florian Mickler 2011-06-27 21:20:55 UTC
Ah yes. Thanks for the reference. I just send Arjan a patch for latencytop, though I don't really understand the need for this renaming.
Comment 4 Rafael J. Wysocki 2011-07-10 12:32:30 UTC
On Sunday, July 10, 2011, Pekka Enberg wrote:
> On Sun, Jul 10, 2011 at 1:58 PM, Rafael J. Wysocki <rjw@sisk.pl> wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.38 and 2.6.39.
> >
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.38 and 2.6.39.  Please verify if it still should
> > be listed and let the tracking team know (either way).
> >
> > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=38132
> > Subject         : [Warning] 2.6.39.x latencytop
> > Submitter       : Andrew Watts <akwatts@ymail.com>
> > Date            : 2011-06-14 17:07 (27 days old)
> > Message-ID      : <80098.5633.qm@web111013.mail.gq1.yahoo.com>
> > References      : http://marc.info/?l=linux-kernel&m=130807128506490&w=2
> 
> This is a WARN_ON added in commit 6752ab4a ("tracing: Deprecate
> tracing_enabled for tracing_on") that lets the user know about
> deprecated ABI. It's somewhat unfortunate that there's no mention in
> the changelog if everyone agreed on the deprecation or not...
> 
> That said, assuming the deprecation is OK (hi Steven, Frederic, Ingo!)
> I think this issue can be closed.
Comment 5 Florian Mickler 2011-07-10 12:41:55 UTC
*** Bug 37652 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.