Bug 38062 - Lenovo Ideapad S10-3C keyboard isn't working with ACPI enabled.
Summary: Lenovo Ideapad S10-3C keyboard isn't working with ACPI enabled.
Status: CLOSED DUPLICATE of bug 30942
Alias: None
Product: ACPI
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 blocking
Assignee: acpi_other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-23 06:52 UTC by Ivan Sukin
Modified: 2011-07-30 04:33 UTC (History)
0 users

See Also:
Kernel Version: Any 2.6 kernel
Tree: Mainline
Regression: No


Attachments
ACPI related errors from dmesg (2.13 KB, text/plain)
2011-06-23 07:30 UTC, Ivan Sukin
Details

Description Ivan Sukin 2011-06-23 06:52:00 UTC
Original keyboard of my Lenovo Ideapad S10-3C is only working when I pass "noapic acpi=off" bootparameters to kernel. Any external keyboards are working perfectly. Also any other free OSes (I've tried latest FreeBSD, OpenBSD, NetBSD, Plan9) has similar problem. Some people say that Linux kernels < 2.5 version doesn't have this problem.

There is a large discussion about this bug in Ubuntu and Gentoo bugtrackers:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/677633
http://bugs.gentoo.org/show_bug.cgi?id=355627
Comment 1 Ivan Sukin 2011-06-23 07:30:58 UTC
Created attachment 63242 [details]
ACPI related errors from dmesg
Comment 2 Ivan Sukin 2011-06-23 08:02:02 UTC

*** This bug has been marked as a duplicate of bug 30942 ***

Note You need to log in before you can comment on or make changes to this bug.