Bug 3805 - PnP ACPI error
Summary: PnP ACPI error
Status: CLOSED CODE_FIX
Alias: None
Product: ACPI
Classification: Unclassified
Component: Other (show other bugs)
Hardware: i386 Linux
: P2 low
Assignee: Shaohua
URL:
Keywords:
: 3899 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-11-25 08:20 UTC by Oleksij Rempel (fishor)
Modified: 2005-01-21 21:41 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.10-rc1 , rc2
Tree: Mainline
Regression: ---


Attachments
lspci -vv (5.03 KB, text/plain)
2004-11-25 08:36 UTC, Oleksij Rempel (fishor)
Details
interrupts (417 bytes, text/plain)
2004-11-25 08:41 UTC, Oleksij Rempel (fishor)
Details
dsdt (19.62 KB, application/octet-stream)
2004-11-25 09:13 UTC, Oleksij Rempel (fishor)
Details
patch to mask the error message (1.46 KB, patch)
2004-11-25 17:44 UTC, Shaohua
Details | Diff

Description Oleksij Rempel (fishor) 2004-11-25 08:20:46 UTC
Distribution: Debian Sarge 
 
pnp: PnP ACPI init 
acpi_bus-0073 [10] acpi_bus_get_device   : Error getting context for object 
[c1138508] 
acpi_bus-0073 [10] acpi_bus_get_device   : Error getting context for object 
[c1138288] 
acpi_bus-0073 [10] acpi_bus_get_device   : Error getting context for object 
[c1137f48] 
acpi_bus-0073 [10] acpi_bus_get_device   : Error getting context for object 
[c7fc42c8] 
pnp: PnP ACPI: found 14 devices
Comment 1 Oleksij Rempel (fishor) 2004-11-25 08:36:39 UTC
Created attachment 4138 [details]
lspci -vv
Comment 2 Oleksij Rempel (fishor) 2004-11-25 08:41:46 UTC
Created attachment 4139 [details]
interrupts
Comment 3 Oleksij Rempel (fishor) 2004-11-25 09:13:24 UTC
Created attachment 4140 [details]
dsdt
Comment 4 Shaohua 2004-11-25 16:58:37 UTC
Actually this error is indead a warning. It means the device isn't present. It 
doesn't change anything. Possibly the message itself (it claims it's an error) 
mislead you.
Ok, I will provide a patch for this issue, since many people complain it. But 
it indead is harmless.
Comment 5 Shaohua 2004-11-25 17:44:11 UTC
Created attachment 4142 [details]
patch to mask the error message

Ok, this patch will mask the message.
Comment 6 Oleksij Rempel (fishor) 2004-11-26 03:38:01 UTC
Thank you, David. 
 
Linux Plug and Play Support v0.97 (c) Adam Belay 
pnp: PnP ACPI init 
pnp: PnP ACPI: found 12 devices 
PnPBIOS: Disabled by ACPI 
 
 
 
Comment 7 Len Brown 2004-12-05 20:12:36 UTC
patch in comment #5 applied to acpi-test tree 
Comment 8 Shaohua 2004-12-14 17:17:03 UTC
*** Bug 3899 has been marked as a duplicate of this bug. ***
Comment 9 Len Brown 2005-01-21 21:41:12 UTC
shipped in 2.6.11-rc1 -- closing. 

Note You need to log in before you can comment on or make changes to this bug.