Bug 37882 - WARNING: at ../kernel/printk.c:322
WARNING: at ../kernel/printk.c:322
Status: CLOSED DOCUMENTED
Product: Process Management
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: process_other
:
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-06-19 15:45 UTC by Maciej Rutecki
Modified: 2011-06-26 21:27 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.38
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-06-19 15:45:56 UTC
Subject    : WARNING: at ../kernel/printk.c:322
Submitter  : Christian Kujau <lists@nerdbynature.de>
Date       : 2011-06-11 7:17
Message-ID : alpine.DEB.2.01.1106110003030.9183@trent.utfs.org
References : http://marc.info/?l=linux-kernel&m=130777668512981&w=2

This entry is being used for tracking a regression from 2.6.39. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Christian Kujau 2011-06-19 19:54:30 UTC
It does not seem to be a regression from 2.6.39 - in the syslog-ng bugtracker[0] the problem had been reported for 2.6.38+ too and now I'm not really sure if that's that's a syslog-ng bug or something else. I'd understand the "deprecated" message, but I was kinda worried by the WARNING. That's why I sent this to lkml.

Thanks,
Christian.

[0] https://bugzilla.balabit.com/show_bug.cgi?id=108
Comment 2 Tony Breeds 2011-06-20 01:06:25 UTC
This is a syslog-ng problem.  https://bugzilla.balabit.com/show_bug.cgi?id=108#c14
holds the answer.  Yes the kernel accepts CAP_SYS_ADMIN but syslog-ng should be moved over to use CAP_SYSLOG on newer kernels.
Comment 3 Tony Breeds 2011-06-20 01:08:33 UTC
Also this may have been found on ppc32 but it's specific to that platform.  This is generic code.

Bug should be closed or at least assigned elsewhere.

Note You need to log in before you can comment on or make changes to this bug.