Bug 37772 - Sometimes, sound disappears and doesn't want to idle.
Sometimes, sound disappears and doesn't want to idle.
Status: RESOLVED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA)
All Linux
: P1 normal
Assigned To: Jaroslav Kysela
:
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-06-17 22:06 UTC by merkil
Modified: 2012-06-27 13:52 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.39.1
Tree: Mainline
Regression: Yes


Attachments

Description merkil 2011-06-17 22:06:27 UTC
Using a home compiled kernel 2.6.39.1, after having listened to music on streaming websites (Flash), sounds suddenly turns off (I can't hear anything).

I configured my kernel with these options :

CONFIG_SND_HDA_POWER_SAVE=y
CONFIG_SND_HDA_POWER_SAVE_DEFAULT=1

I distinctly hears when my sound goes power saving mode by a "click" sound, But it doesn't occurs after the sound loss described above and it stays in an active state.

Here is my .config : http://pastebin.com/r8db20Xm
Result of dmesg : http://pastebin.com/ntCgr9TW
lspci : http://pastebin.com/ef3JzhRG

uname -a : Linux miochan 2.6.39-mio #1 Sat Jun 11 15:37:48 CEST 2011 x86_64 AMD Athlon(tm) Processor TF-20 AuthenticAMD GNU/Linux

PS : I'm not able to reproduce this bug as it occurs rather randomly, but when it appears, I have to reboot to solve it.
It began happening with 2.6.39.
Comment 1 Takashi Iwai 2011-06-18 06:39:56 UTC
A few things to check:
 - Is this a regression?
 - alsa-info.sh outputs at both good and bad states on this kernel
 - If it's a regression, again alsa-info.sh outpus with both good and bad-working kernels

Check the content /sys/module/snd_hda_intel/parameters/power_save file.  This value can be changed dynamically, and some daemon like pm-utils may have changed it.  For more quick testing, you can set it (via echo) by yourself, and start/stop some sound program and see.

Once when you can reproduce the problem reliably, test it with the older (working) kernel to confirm the points above.

Thanks.
Comment 2 merkil 2011-06-18 08:31:49 UTC
I tried to reproduce some scenarios, and it seems to occur when I change the sound volume during I load a flash animation (2 of my keys are bound to the commands "amixer sset Master 1+" and "amixer sset Master 1-").
At this moment, flash seems to freeze and even VLC Media Player cannot play any sound.
Finally, it appears to be solvable by simply closing my web browser, so I think it's rather a Flash issue. But I wasn't able to make Flash hang with Linux 2.6.32, so it could also be a regression...

Here are alsa_info results :

* With Linux 2.6.32   : http://pastebin.com/pQmux2nx (with that conf : http://pastebin.com/JdP7fepx, default on Arch Linux)
* With Linux 2.6.39.1 : http://pastebin.com/kuB9Sifr (with that conf : http://pastebin.com/r8db20Xm, home compiled kernel)

Well, I think I can't provide more informations, sorry.
Comment 3 Takashi Iwai 2011-06-18 08:47:43 UTC
2.6.32 is a bit too far to compare with 2.6.39.  Could you figure out whether it's a kernel regression, and which kernel version it happens first?

And, can it be related with PulseAudio?

Also, could you provide alsa-info.sh outputs of 2.6.39 for both working and non-working cases?
Comment 4 merkil 2011-06-18 08:59:01 UTC
Now, I can't compile kernels, but I'll try later.

Here is 2.6.39 when Flash hangs in my web browser : http://pastebin.com/7eTixNHJ
And when it works (for example, without any flash animation) : http://pastebin.com/Aqnd9egN
As you can see, there is a little difference.

It's not related with Pulseaudio, it isn't even installed.
Comment 5 merkil 2011-06-18 09:15:03 UTC
Oh, and I can't reproduce this issue with the default binary kernel provided by Arch Linux packagers (config : http://pastebin.com/CFpdq80Q).
So it's somehow related to my configuration, maybe power saving stuff.

Note You need to log in before you can comment on or make changes to this bug.