Bug 37762 - No display when resuming on HP DV6 dual radeon laptop
Summary: No display when resuming on HP DV6 dual radeon laptop
Status: RESOLVED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-17 16:56 UTC by Johan Brannlund
Modified: 2013-12-23 13:53 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.38
Tree: Mainline
Regression: No


Attachments
syslog from suspend/resume cycle (43.45 KB, text/plain)
2011-06-17 16:56 UTC, Johan Brannlund
Details
acpidump output (270.03 KB, text/plain)
2011-08-25 15:38 UTC, Johan Brannlund
Details

Description Johan Brannlund 2011-06-17 16:56:31 UTC
Created attachment 62612 [details]
syslog from suspend/resume cycle

When resuming from suspend-to-ram on a HP DV6 3167-ca laptop, the display does not come back to life, although everything else seems to work - I can type blind and reboot the machine etc.

This laptop has two radeon cards:

$ lspci -vnn |grep VGA
01:05.0 VGA compatible controller [0300]: ATI Technologies Inc M880G [Mobility Radeon HD 4200] [1002:9712] (prog-if 00 [VGA controller])
02:00.0 VGA compatible controller [0300]: ATI Technologies Inc Redwood [Radeon HD 5600 Series] [1002:68c1] (rev ff) (prog-if ff)

vgaswitcheroo works as expected and the power settings in /.../vgaswitcheroo/switch do not affect the outcome (i.e. display dead after resume). The suspend is done when running on the 4200 series card.

I am attaching a syslog. The line

kernel: [  191.930153] radeon 0000:02:00.0: Refused to change power state, currently in D3

appears to be the smoking gun. This is on Ubuntu Natty, which runs a kernel based on 2.6.38. However, Chris (who I'm including on this bug) has the same type of laptop. He has tried with various mainline kernels, including 3.0-rc kernels and gets the same result. Also, he said resume *does* work with the latest ATI proprietary driver.
Comment 1 Johan Brannlund 2011-07-30 18:33:37 UTC
As a test, I tried doing

# echo core > /sys/power/pm_test
# echo mem >/sys/power/state

and the display comes back like it's supposed to.
Comment 2 Johan Brannlund 2011-08-25 15:38:53 UTC
Created attachment 70162 [details]
acpidump output
Comment 3 Alan 2013-12-23 13:53:57 UTC
If this is still present in modern kernels please update the bug

Note You need to log in before you can comment on or make changes to this bug.