Bug 37742 - iwlagn with IOMMU enabled causes DMA Write faults
iwlagn with IOMMU enabled causes DMA Write faults
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 normal
Assigned To: Stanislaw Gruszka
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-17 09:36 UTC by Julian Stecklina
Modified: 2012-04-01 10:31 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.0.0-rc3
Tree: Mainline
Regression: No


Attachments
kernel log (61.22 KB, text/plain)
2011-06-17 09:36 UTC, Julian Stecklina
Details

Description Julian Stecklina 2011-06-17 09:36:31 UTC
Created attachment 62492 [details]
kernel log

My wifi device causes DMA faults during initialization and association with an AP. This is on a ThinkPad X201s with the 6000AGN wifi (see below). IOMMU is enabled via intel_iommu=igfx_off commandline option. As far as I can tell the wifi works, although it might take longer to associate to an AP than without the IOMMU enabled.

(complete log is attached)
[   62.238298] DRHD: handling fault status reg 2
[   62.238305] DMAR:[DMA Write] Request device [02:00.0] fault addr ffe82000 
[   62.238307] DMAR:[fault reason 05] PTE Write access is not set
[   62.642904] DRHD: handling fault status reg 2
[   62.642912] DMAR:[DMA Write] Request device [02:00.0] fault addr ffe30000 
[   62.642914] DMAR:[fault reason 05] PTE Write access is not set
[   64.006425] wlan0: direct probe to 08:17:35:82:b0:2d (try 1/3)
[   64.265438] DRHD: handling fault status reg 2
[   64.265445] DMAR:[DMA Write] Request device [02:00.0] fault addr ffea0000 
[   64.265447] DMAR:[fault reason 05] PTE Write access is not set


02:00.0 Network controller: Intel Corporation WiFi Link 6000 Series (rev 35)
	Subsystem: Intel Corporation WiFi Link 6000 Series 3x3 6000AGN
	Flags: bus master, fast devsel, latency 0, IRQ 45
	Memory at f2400000 (64-bit, non-prefetchable) [size=8K]
	Capabilities: [c8] Power Management version 3
	Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [e0] Express Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Device Serial Number 00-24-d7-ff-ff-5f-f1-64
	Kernel driver in use: iwlagn
	Kernel modules: iwlagn
Comment 1 Stanislaw Gruszka 2012-02-13 12:58:25 UTC
Does it still happen on new kernel? If so, can you compile driver with CONFIG_IWLWIFI_DEBUG and load module with gather logs as described in
https://bugzilla.kernel.org/show_bug.cgi?id=35932#c2
(use iwlwifi module instead of iwl4965 of course) Then we will see where exactly DMAR problems happen.
Comment 2 Stanislaw Gruszka 2012-02-13 13:00:50 UTC
Hmm Wey @ intel is CCed here and ignore that bug since more that half a year, that's kinda disappointing.
Comment 3 Stanislaw Gruszka 2012-02-13 13:40:02 UTC
(In reply to comment #2)
> Hmm Wey @ intel is CCed here and ignore that bug since more that half a year,
> that's kinda disappointing.
I forgot bugzilla was down, shame on me, sorry Wey!
Comment 4 wey-yi.w.guy 2012-02-13 14:09:23 UTC
no problem :-), I am also very interest on root cause the problem here. 

Wey
Comment 5 Julian Stecklina 2012-02-13 15:20:39 UTC
Can't reproduce this with 3.2.5 right now. I'll leave the IOMMU enabled for now and report back if it pops up again.

(Did I say that VT-d support on laptops rocks? Thanks Intel!)
Comment 6 Stanislaw Gruszka 2012-04-01 10:31:28 UTC
This problem is fixed.

Note You need to log in before you can comment on or make changes to this bug.