Bug 37532 - 3.0.0-rc1-git5 - INFO: suspicious rcu_dereference_check() usage
3.0.0-rc1-git5 - INFO: suspicious rcu_dereference_check() usage
Status: CLOSED DUPLICATE of bug 37222
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 normal
Assigned To: platform_x86_64@kernel-bugs.osdl.org
:
Depends on:
Blocks: 36912
  Show dependency treegraph
 
Reported: 2011-06-15 19:42 UTC by Maciej Rutecki
Modified: 2011-06-26 21:23 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.0.0-rc1-git5
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-06-15 19:42:41 UTC
Subject    : 3.0.0-rc1-git5 - INFO: suspicious rcu_dereference_check() usage
Submitter  : Miles Lane <miles.lane@gmail.com>
Date       : 2011-06-06 2:24
Message-ID : BANLkTimW5s2DnTJt-SqWaje2vAURhPa4yw@mail.gmail.com
References : http://marc.info/?l=linux-kernel&m=130732710526097&w=2

This entry is being used for tracking a regression from 2.6.39. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Lin Ming 2011-06-20 01:31:08 UTC
Duplicate with bug 37222 and it was fixed.

http://git.kernel.org/?p=linux/kernel/git/x86/linux-2.6-tip.git;a=commit;h=6c6c54e180

commit 6c6c54e1807faf116724451ef2bd14993780470a
Author: Peter Zijlstra <peterz@infradead.org>
Date:   Fri Jun 3 17:37:07 2011 +0200

    sched: Fix/clarify set_task_cpu() locking rules
Comment 2 Rafael J. Wysocki 2011-06-26 21:22:36 UTC

*** This bug has been marked as a duplicate of bug 37222 ***

Note You need to log in before you can comment on or make changes to this bug.