Bug 37432 - sdhci-pci fails on 3.0.0-rc1 on Dell E6510
sdhci-pci fails on 3.0.0-rc1 on Dell E6510
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: PCI
All Linux
: P1 normal
Assigned To: drivers_pci@kernel-bugs.osdl.org
:
Depends on:
Blocks: 36912
  Show dependency treegraph
 
Reported: 2011-06-13 17:02 UTC by Rafael J. Wysocki
Modified: 2011-08-28 19:18 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.0-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2011-06-13 17:02:47 UTC
Subject    : sdhci-pci fails on 3.0.0-rc1 on Dell E6510
Submitter  : Oliver Hartkopp <socketcan@hartkopp.net>
Date       : 2011-06-07 20:06
References : http://article.gmane.org/gmane.linux.kernel.mmc/8442

This entry is being used for tracking a regression from 2.6.39. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2011-06-13 17:04:17 UTC
First-Bad-Commit : da7822e5ad71ec9b745b412639f1e5e0ba795a20

Author: Yinghai Lu <yinghai@kernel.org>
Date:   Thu May 12 17:11:37 2011 -0700

    PCI: update bridge resources to get more big ranges when allocating space (again)
    
    With Ram's fixes, this should be safe to do again.  So let's give it
    another try.
    
    BIOS separates IO ranges between several IOHs, and on some slots, BIOS
    assigns resources to a bridge, but stops assigning resources to the
    device under that bridge, because the device needs a big resource.
    
    So:
    1. allocate resources and record the failed device resources
    2. clear the BIOS assigned resources of the parent bridge of failing device
    3. go back and call pci assign unassigned
    4. if it still fails, go up the tree, clear more bridges. and try again
    
    Now Ram's allocate requested resource already got into mainline. could
    put this one again.
    
    Reviewed-by: Ram Pai <linuxram@us.ibm.com>
    Signed-off-by: Yinghai Lu <yinghai@kernel.org>
    Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
Comment 2 Florian Mickler 2011-07-02 19:58:26 UTC
References: https://lkml.org/lkml/2011/6/23/660
Comment 3 Rafael J. Wysocki 2011-08-15 17:35:52 UTC
On Monday, August 15, 2011, Oliver Hartkopp wrote:
> On 14.08.2011 21:02, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.39 and 3.0.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.39 and 3.0.  Please verify if it still should
> > be listed and let the tracking team know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=37432
> > Subject		: sdhci-pci fails on 3.0.0-rc1 on Dell E6510
> > Submitter	: Oliver Hartkopp <socketcan@hartkopp.net>
> > Date		: 2011-06-07 20:06 (69 days old)
> 
> the regression has been solved for 3.0 by disabling the problematic code here:
> 
> http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=commitdiff;h=f483d3923dc3a6394c483e28ccb3fe700bdf399e
> 
> When the new commandline argument 'pci=realloc' is not set (which is the
> default) the buggy code is disabled.
> 
> Therefore this bug can be closed on the 2.6.39 -> 3.0 regression list.

Note You need to log in before you can comment on or make changes to this bug.