Bug 37392 - Firmware fails to load aften resuming
Firmware fails to load aften resuming
Status: RESOLVED OBSOLETE
Product: v4l-dvb
Classification: Unclassified
Component: dvb-usb
All Linux
: P1 normal
Assigned To: dvb-usb
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2011-06-13 08:26 UTC by Xavier Poirot
Modified: 2013-12-23 13:48 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.39
Tree: Mainline
Regression: No


Attachments

Description Xavier Poirot 2011-06-13 08:26:09 UTC
I've installed a firmware myself in /lib/firmware to watch TV.
This firmware is loading successfully on _bootup_ and works good.
Although, the firmware is NOT loading on resuming system ! Kernel cannot find it.

[36374.199184] dvb-usb: found a 'AVerMedia A309' in cold state, will try to load a firmware
[36434.396465] dvb-usb: did not find the firmware file. (dvb-usb-af9015.fw) Please see linux/Documentation/dvb/ for more details on firmware-problems. (-2)
[36434.396473] dvb_usb_af9015: probe of 2-8:1.0 failed with error -2

The .fw file is still here in the system, of course, but the kernel sounds like he cannot find it.

Moreover, on resuming computer, the resuming process seems to be seeking for the firmware (it's loading loading loading) for 1 full minute, and then give up and let me log in again.

I've found another person who experienced the same problem with a wireless card and its firmware here : http://sourceforge.net/tracker/?func=detail&aid=2876241&group_id=42302&atid=447449
This person told me by experience that it's more like a _GENERAL FIRMWARE_ problem and not located exclusively for a few kinds of firmwares, so maybe you guys should have a look more deeply in it ?

You will, of course, find good precisions in the bug I linked above, because it has been solved (but only for the precised firmware which is not mine).
Comment 1 Rafael J. Wysocki 2011-06-13 16:49:55 UTC
Unfortunately, this is a driver problem.  The driver (in this particular
case, dvb-usb) has to be fixed not to do things it shouldn't do.

Note You need to log in before you can comment on or make changes to this bug.