Bug 3734 - Need smart battery support - Acer travelmate 3202
Need smart battery support - Acer travelmate 3202
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Power-Battery
i386 Linux
: P2 normal
Assigned To: Vladimir Lebedev
:
: 3368 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 15:16 UTC by Jimmy Baeten
Modified: 2006-07-19 04:48 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.9
Tree: Mainline
Regression: ---


Attachments
acpicmp dump (78.86 KB, text/plain)
2004-11-12 06:39 UTC, Jimmy Baeten
Details
acpi dump for TravelMate 2303LCi (78.86 KB, text/plain)
2005-02-03 03:59 UTC, Vladimir Lebedev
Details
acpi dump for TravelMate 2303LCi (78.86 KB, text/plain)
2005-02-03 03:59 UTC, Vladimir Lebedev
Details
SBS drivers (65.27 KB, patch)
2006-05-18 08:51 UTC, Vladimir Lebedev
Details | Diff
Version for 2.6.17-git* (64.67 KB, patch)
2006-06-30 12:58 UTC, Vladimir Lebedev
Details | Diff
improved version (6.68 KB, patch)
2006-07-19 04:48 UTC, Vladimir Lebedev
Details | Diff

Description Jimmy Baeten 2004-11-11 15:16:59 UTC
Distribution: Gentoo Linux
Hardware Environment: Acer travelmate 2302
Software Environment: /
Problem Description:

The ACPI module is not retreiving any information on battery power or the ac
adapter on my laptop.

Steps to reproduce:
Comment 1 Shaohua 2004-11-12 00:53:03 UTC
You possibly have a smart battery, please attach your acpidmp.
Comment 2 Jimmy Baeten 2004-11-12 06:39:16 UTC
Created attachment 4021 [details]
acpicmp dump

here is the dump from acpidmp, its 80mb
Comment 3 Shaohua 2004-11-14 16:56:24 UTC
Yes, I'm certainly sure you have a smart battery. No smart battery driver 
support in Linux currently.
Comment 4 Shaohua 2004-11-14 16:57:52 UTC
*** Bug 3368 has been marked as a duplicate of this bug. ***
Comment 5 Shaohua 2004-11-14 17:01:57 UTC
Somebody (on acpi-devel@lists.sourceforge.net maillist) is working on a smart 
battery driver, please wait.
Comment 6 Vladimir Lebedev 2005-02-03 03:48:04 UTC
Acer TravelMate 2300LCi seems to have the same problem.
DSDT shows no battery device.
But if there were a smart battery, shouldn't we see a SBST
in the RSDT?
Comment 7 Vladimir Lebedev 2005-02-03 03:59:47 UTC
Created attachment 4508 [details]
acpi dump for TravelMate 2303LCi
Comment 8 Vladimir Lebedev 2005-02-03 03:59:56 UTC
Created attachment 4509 [details]
acpi dump for TravelMate 2303LCi
Comment 9 Alexey Starikovskiy 2005-02-04 03:15:35 UTC
SmartBattery driver from Rich Townsend :
http://shayol.bartol.udel.edu/~rhdt/download/acpi_sbs-20050119.tar.gz
is able to find smart battery on TravelMate 2303LCi.
It requires two functions to be exported from the ec driver (acpi_ec_read and
acpi_ec_write).

ac_adapter is still missing thow.
Comment 10 Vladimir Lebedev 2006-05-18 08:51:21 UTC
Created attachment 8137 [details]
SBS drivers

These SBS drivers are based of Ducrot Bruno and Rich Townsend drivers,

Config:
Drivers depend on I2C (Drivers Devices -?? I2C support	=  Y)

These drivers work fine on Acer 2300.
I am interested in their behavior on your system. 
Also: all data	in ??/proc/acpi/battery and /proc /acpi/ac_adapter ?? files are
updated each  minute.

I  would like to hear your  opinion and comments.

All ideas and suggestions are wellcome.
Comment 11 Vladimir Lebedev 2006-06-30 12:58:31 UTC
Created attachment 8467 [details]
Version for  2.6.17-git*  


This version is not compatible with 2.6.17.2/3 stable version (function
acpi_os_execute() is absent in 2.6.17.2/3)
Comment 12 Len Brown 2006-07-01 08:34:26 UTC
applied patches in comment #11 to acpi-test  
Comment 13 Len Brown 2006-07-05 17:57:30 UTC
shipped at linux-2.6.17-git25, in time for linux-2.6.18-rc1.
closed.
Comment 14 Vladimir Lebedev 2006-07-19 04:48:49 UTC
Created attachment 8586 [details]
improved version

For  2.6.18*  versions.
The main features are:
a) the time of ac_adapter checking - about 5 seconds.
a) the time of battery checking - the same 60 seconds.
Len, please add it to the next ACPI update.

Note You need to log in before you can comment on or make changes to this bug.