Bug 37312 - Intel 5100 wifi stopped working with 2.6.39.1
Intel 5100 wifi stopped working with 2.6.39.1
Status: CLOSED OBSOLETE
Product: Networking
Classification: Unclassified
Component: Wireless
All Linux
: P1 blocking
Assigned To: networking_wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-06-12 12:43 UTC by Thibault Dory
Modified: 2012-06-14 17:59 UTC (History)
8 users (show)

See Also:
Kernel Version: 2.6.39.1
Tree: Mainline
Regression: Yes


Attachments
Dmesg output (131.43 KB, text/plain)
2011-06-12 12:43 UTC, Thibault Dory
Details

Description Thibault Dory 2011-06-12 12:43:46 UTC
Created attachment 61652 [details]
Dmesg output

After updating the kernel to 2.6.39.1 (I'm using Arch linux 64bit), the wifi stopped working. It associate then crash with this message, repeated a lot of time :

[  140.348707] wlan0: RX ReassocResp from 00:19:70:34:0c:75 (capab=0x431 status=0 aid=2)
[  140.348711] wlan0: associated
[  140.348717] wlan0: failed to insert STA entry for the AP (error -17)
[  140.348722] ------------[ cut here ]------------
[  140.348746] WARNING: at net/wireless/mlme.c:364 cfg80211_send_assoc_timeout+0xb1/0x150 [cfg80211]()
[  140.348749] Hardware name: INVALID
[  140.348750] Modules linked in: loop ipv6 usbhid hid snd_hda_codec_hdmi uvcvideo videodev snd_hda_codec_si3054 snd_hda_codec_realtek media v4l2_compat_ioctl32 i2c_core arc4 ecb snd_hda_intel ir_lirc_codec lirc_dev snd_hda_codec ir_sony_decoder snd_hwdep snd_pcm iwlagn tg3 ir_jvc_decoder uhci_hcd snd_timer joydev rc_rc6_mce ir_rc6_decoder libphy snd ehci_hcd usbcore r592 ite_cir ir_rc5_decoder intel_gtt mac80211 firewire_ohci soundcore ideapad_laptop asus_laptop sdhci_pci sdhci serio_raw mmc_core ir_nec_decoder pcspkr sparse_keymap memstick sg iTCO_wdt iTCO_vendor_support firewire_core snd_page_alloc rc_core psmouse video cfg80211 evdev rfkill crc_itu_t ext2 thermal fan button battery ac cpufreq_conservative cpufreq_userspace cpufreq_powersave cpufreq_ondemand acpi_cpufreq freq_table processor mperf fuse sr_mod cdrom ext4 mbcache jbd2 crc16 sd_mod ahci libahci libata scsi_mod
[  140.348822] Pid: 171, comm: kworker/u:3 Not tainted 2.6.39-ARCH #1
[  140.348825] Call Trace:
[  140.348834]  [<ffffffff8105b8ef>] warn_slowpath_common+0x7f/0xc0
[  140.348838]  [<ffffffff8105b94a>] warn_slowpath_null+0x1a/0x20
[  140.348847]  [<ffffffffa0203d11>] cfg80211_send_assoc_timeout+0xb1/0x150 [cfg80211]
[  140.348859]  [<ffffffffa02d27d9>] ieee80211_assoc_done+0xc9/0x160 [mac80211]
[  140.348869]  [<ffffffffa02d4046>] ieee80211_work_work+0x246/0x1390 [mac80211]
[  140.348874]  [<ffffffff813e5c2f>] ? schedule+0x33f/0xad0
[  140.348884]  [<ffffffffa02d3e00>] ? free_work+0x20/0x20 [mac80211]
[  140.348889]  [<ffffffff81077f7e>] process_one_work+0x11e/0x4c0
[  140.348899]  [<ffffffff8107890f>] worker_thread+0x15f/0x350
[  140.348903]  [<ffffffff810787b0>] ? manage_workers.isra.29+0x230/0x230
[  140.348906]  [<ffffffff8107d6fc>] kthread+0x8c/0xa0
[  140.348910]  [<ffffffff813eac64>] kernel_thread_helper+0x4/0x10
[  140.348913]  [<ffffffff8107d670>] ? kthread_worker_fn+0x190/0x190
[  140.348916]  [<ffffffff813eac60>] ? gs_change+0x13/0x13
[  140.348918] ---[ end trace ed549c4b8d30879a ]---
[  143.354327] wlan0: deauthenticated from 00:19:70:34:0c:75 (Reason: 2)

Going back to 2.6.38 solves the problem. 
Please ask if you need more information.

Thibault Dory
Comment 1 Thibault Dory 2011-08-15 12:37:57 UTC
Well the problem is still present (very similar but maybe a little different, I did not copy the log this time) in linux 3.0.1
Comment 2 John W. Linville 2012-01-13 19:15:40 UTC
Does this problem persist with 3.2 kernels?

Note You need to log in before you can comment on or make changes to this bug.