Bug 37222 - 3.0.0-rc1-git3 -- kernel/sched.c:619 invoked rcu_dereference_check() without protection!
Summary: 3.0.0-rc1-git3 -- kernel/sched.c:619 invoked rcu_dereference_check() without ...
Status: CLOSED CODE_FIX
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: platform_x86_64@kernel-bugs.osdl.org
URL:
Keywords:
: 37532 (view as bug list)
Depends on:
Blocks: 36912
  Show dependency tree
 
Reported: 2011-06-11 16:26 UTC by Maciej Rutecki
Modified: 2011-06-26 21:22 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.0.0-rc1-git3
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-06-11 16:26:41 UTC
Subject    : 3.0.0-rc1-git3 -- kernel/sched.c:619 invoked rcu_dereference_check() without protection!
Submitter  : Miles Lane <miles.lane@gmail.com>
Date       : 2011-06-04 3:22
Message-ID : BANLkTikHS7TuFhm3cfJ+Y=erWDaAwuE_TA@mail.gmail.com
References : http://marc.info/?l=linux-kernel&m=130715775803343&w=2

This entry is being used for tracking a regression from 2.6.39. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2011-06-13 17:25:38 UTC
On Monday, June 13, 2011, Lin Ming wrote:
> 
> > From: Rafael J. Wysocki <rjw@sisk.pl>
> > Date: Mon, Jun 13, 2011 at 4:30 AM
> > Subject: [Bug #37222] 3.0.0-rc1-git3 -- kernel/sched.c:619 invoked
> > rcu_dereference_check() without protection!
> > To: Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
> > Cc: Kernel Testers List <kernel-testers@vger.kernel.org>, Maciej
> > Rutecki <maciej.rutecki@gmail.com>, Florian Mickler
> > <florian@mickler.org>, Miles Lane <miles.lane@gmail.com>
> > 
> > 
> > This message has been generated automatically as a part of a summary report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.39.  Please verify if it still should be listed and let the
> > tracking team
> > know (either way).
> > 
> > 
> > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=37222
> > Subject         : 3.0.0-rc1-git3 -- kernel/sched.c:619 invoked
> > rcu_dereference_check() without protection!
> > Submitter       : Miles Lane <miles.lane@gmail.com>
> > Date            : 2011-06-04 3:22 (9 days old)
> > 
> 
> This was fixed already.
>
> http://git.kernel.org/?p=linux/kernel/git/x86/linux-2.6-tip.git;a=commit;h=6c6c54e180
> 
> commit 6c6c54e1807faf116724451ef2bd14993780470a
> Author: Peter Zijlstra <peterz@infradead.org>
> Date:   Fri Jun 3 17:37:07 2011 +0200
> 
>     sched: Fix/clarify set_task_cpu() locking rules
Comment 2 Rafael J. Wysocki 2011-06-26 21:22:36 UTC
*** Bug 37532 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.