Bug 36962 - [Regression 2.6.39][nouveau][bisected?] leaving fullscreen XV "crashes" with KDE desktop effects enabled
Summary: [Regression 2.6.39][nouveau][bisected?] leaving fullscreen XV "crashes" with ...
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks: 32012
  Show dependency tree
 
Reported: 2011-06-08 19:39 UTC by Maciej Rutecki
Modified: 2011-06-22 08:28 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.39
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-06-08 19:39:50 UTC
Subject    : [Regression 2.6.39][nouveau][bisected?] leaving fullscreen XV "crashes" with KDE desktop effects enabled
Submitter  : Jan Seiffert <kaffeemonster@googlemail.com>
Date       : 2011-05-25 2:32
Message-ID : BANLkTimd6nvXTbn2hM+cKDNKFpxzsQLHog@mail.gmail.com
References : http://marc.info/?l=linux-kernel&m=130629073407685&w=2

This entry is being used for tracking a regression from 2.6.38. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Maxim Levitsky 2011-06-20 15:04:12 UTC
This is very interesting beast.

First of all, I also notice similar problem with compiz, not that often though.
Once again, open totem, maximize, minimize, boom.
It doesn't happen often, but when I start watching videos often it bites.
Also XV sometimes hangs the system without any user intervention.

Now that commit that Jan Seiffert bisected looks very very suspicions.
I can say I almost sure he found something very interesting.

Kudos to Jan Seiffert
Comment 2 Maxim Levitsky 2011-06-20 15:09:27 UTC
On Mon, 2011-06-20 at 15:04 +0000, bugzilla-daemon@bugzilla.kernel.org
wrote: 
> https://bugzilla.kernel.org/show_bug.cgi?id=36962
> 
> 
> Maxim Levitsky <maximlevitsky@gmail.com> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                  CC|                            |maximlevitsky@gmail.com
> 
> 
> 
> 
> --- Comment #1 from Maxim Levitsky <maximlevitsky@gmail.com>  2011-06-20
> 15:04:12 ---
> This is very interesting beast.
> 
> First of all, I also notice similar problem with compiz, not that often
> though.
> Once again, open totem, maximize, minimize, boom.
> It doesn't happen often, but when I start watching videos often it bites.
> Also XV sometimes hangs the system without any user intervention.
> 
> Now that commit that Jan Seiffert bisected looks very very suspicions.
> I can say I almost sure he found something very interesting.
> 
> Kudos to Jan Seiffert
> 


I have seen that on my NV86, and that could be the reason for hangs I
have quite often (at least one type of them...)

Best regards,
Maxim Levitsky
Comment 3 Marcin Slusarz 2011-06-20 16:32:43 UTC
Hmm, few days ago on irc someone else reported similar bug and Ben provided this patch: http://members.iinet.net.au/~skeggsb/0001-drm-nouveau-fix-assumption-that-semaphore-dmaobj-is-.patch which seemed to fix it.

I'm not sure why he didn't apply it yet.
Comment 4 Jan "RedBully" Seiffert 2011-06-20 19:45:13 UTC
The patch from comment #3 is in nouveau/linux-2.6, but on the second page ;)
http://cgit.freedesktop.org/nouveau/linux-2.6/commit/?id=b16a5a18ff994532120c1d18e678bbc5fb477b62
It is taged as drm-nouveau-fixes, so it should go into Linus Tree.

Hopefully fast!
I had a Linux-3.0.0-rc3 git tree here, applied the 3 patched till drm-nouveau-fixes by hand (left out the endian fix, no BE here), and yes, the problem is gone.

I repeat:
This seems to resolve the problem!

Where can i put my "Tested-by: Jan Seiffert"?

Greetings
Jan
Comment 5 Florian Mickler 2011-06-22 08:28:05 UTC
Merged already in v3.0-rc4:

commit b16a5a18ff994532120c1d18e678bbc5fb477b62
Author: Ben Skeggs <bskeggs@redhat.com>
Date:   Fri Jun 17 23:41:54 2011 +1000

    drm/nouveau: fix assumption that semaphore dmaobj is valid in x-chan sync

Note You need to log in before you can comment on or make changes to this bug.