Bug 3696 - S5 reboots when on AC - broken as of ACPICA 20040715
Summary: S5 reboots when on AC - broken as of ACPICA 20040715
Status: REJECTED DUPLICATE of bug 3669
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Off (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Shaohua
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-04 02:38 UTC by Pierre Ossman
Modified: 2004-11-16 16:31 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.7 + acpi 20040715 and above
Tree: Mainline
Regression: ---


Attachments
debug patch (893 bytes, patch)
2004-11-04 15:58 UTC, Len Brown
Details | Diff

Description Pierre Ossman 2004-11-04 02:38:14 UTC
Distribution: FC2
Hardware Environment: HP/Compaq nx7010

Problem Description:

When S5 is supposed to be entered the machine reboots instead. This _only_
happens when AC power is connected. When running on batteries the machine shuts
down fine.

The bug appeared in acpi patch 20040715 and is still present (vanilla 2.6.9).

Traces shows that the kernel still writes the correct values to enter S5. The
bug must be during the setup of the state change.

Steps to reproduce:

Shut down machine with AC connected.

Similar bugs:

Bug 2253
Bug 2719
Bug 3669

They seem to cover different kernel versions so it might not be the same bug.
Comment 1 Len Brown 2004-11-04 15:25:52 UTC
bug 2252 went away with Linux-2.6.9 but it didn't go away here, so this system
must be different from that one.

Please try out the patch in bug 2109
Comment 2 Len Brown 2004-11-04 15:58:57 UTC
Created attachment 3967 [details]
debug patch

ignore the patch pointer in comment #1.
please try this debug patch.
it undoes the "poweroff regression" fix in ACPICA 20040427
Comment 3 Pierre Ossman 2004-11-05 04:16:50 UTC
Patch had no effect.
Comment 4 Ortwin Glück 2004-11-05 09:48:00 UTC
I am seeing this bug too with 2.6.9.
I recently removed my laptop battery because it is broken, and am running on AC
all the time now. Could this be a reason maybe?
Comment 5 Pierre Ossman 2004-11-05 12:20:06 UTC
It makes no difference if the battery is connected or not here.
Comment 6 Len Brown 2004-11-15 19:32:38 UTC
please test the patch in bug 3669 
Comment 7 Pierre Ossman 2004-11-16 07:35:16 UTC
Patch solves problem.

Great work! =)
Comment 8 Shaohua 2004-11-16 16:31:45 UTC
The patch in bug 3669 solves it, right? I'll mark this one as a duplicate.

*** This bug has been marked as a duplicate of 3669 ***

Note You need to log in before you can comment on or make changes to this bug.