Bug 36712 - 2.6.39 - crash when plugging in a usb memory stick
2.6.39 - crash when plugging in a usb memory stick
Status: CLOSED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-06-05 13:41 UTC by Maciej Rutecki
Modified: 2011-06-15 07:25 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.39
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-06-05 13:41:07 UTC
Subject    : 2.6.39 - crash when plugging in a usb memory stick
Submitter  : Chris Clayton <chris2553@googlemail.com>
Date       : 2011-05-27 8:09
Message-ID : 201105270909.00183.chris2553@googlemail.com
References : http://marc.info/?l=linux-kernel&m=130648376531197&w=2

This entry is being used for tracking a regression from 2.6.38. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Alan Stern 2011-06-13 14:46:49 UTC
Part of the trouble may be related to problems in the SCSI stack which have
been fixed in 3.0-rc2 (I think).  Can you test using that kernel or a later
version?
Comment 2 Chris Clayton 2011-06-15 07:17:03 UTC
On Monday 13 June 2011, bugzilla-daemon@bugzilla.kernel.org wrote:
> https://bugzilla.kernel.org/show_bug.cgi?id=36712
>
>
> Alan Stern <stern@rowland.harvard.edu> changed:
>
>            What    |Removed                     |Added
> ---------------------------------------------------------------------------
>- CC|                            |stern@rowland.harvard.edu
>
>
>
>
> --- Comment #1 from Alan Stern <stern@rowland.harvard.edu>  2011-06-13
> 14:46:49 --- Part of the trouble may be related to problems in the SCSI
> stack which have been fixed in 3.0-rc2 (I think).  Can you test using that
> kernel or a later version?

Alan's probably right. I've been using -rc2 (and now rc3) kernels recently and 
have not experienced the problem again. In fact, this morning I've been 
transferring files from the machine that crashed to a netbook via a USB stick. 
The stick has been plugged in and unplugged several times and it has worked 
flawlessly.

I think this bug entry can be closed. If, in the unlikely event that I get the 
crash again, I'll open a new bug and refer back to this one.


Thanks
Comment 3 Florian Mickler 2011-06-15 07:25:32 UTC
Thank you, closing.

Note You need to log in before you can comment on or make changes to this bug.