Bug 36702 - 2.6.39 kernel panic w/screenshots & kernel cfg link provided
2.6.39 kernel panic w/screenshots & kernel cfg link provided
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: SCSI
All Linux
: P1 normal
Assigned To: linux-scsi@vger.kernel.org
:
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-06-05 13:11 UTC by Maciej Rutecki
Modified: 2011-07-02 12:42 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.39
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-06-05 13:11:18 UTC
Subject    : 2.6.39 kernel panic w/screenshots & kernel cfg link provided
Submitter  : Justin Piszcz <jpiszcz@lucidpixels.com>
Date       : 2011-05-28 12:01
Message-ID : alpine.DEB.2.02.1105280755050.4345@p34.internal.lan
References : http://marc.info/?l=linux-kernel&m=130658411008127&w=2

This entry is being used for tracking a regression from 2.6.38. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Justin Piszcz 2011-06-26 23:01:16 UTC
Hi,

After disconnecting the USB devices as mentioned earlier in the thread (floppy, 2 CDROM drives, flash readers in monitors, etc), the system has not crashed again (yet), I'll get it some more time, but I am guessing that is what it was as there have been no recent crashes, also I am running 2.6.39.2 now.

Linux p34 2.6.39.2 #1 SMP Thu Jun 23 18:46:30 EDT 2011 x86_64 GNU/Linux

If I do not update this in the next few days/weeks it can be resolved and the root cause is most likely those USB devices (I hope, which are disconnected now).
Comment 2 Justin Piszcz 2011-06-27 15:06:21 UTC
Hi,

Right after I wrote this, a few hours later it crashed again for the first time in week and since it hadn't crashed in a while, I had X started so I don't have a crash dump, will leave X off (on console, to capture the next crash) until it crashes again.

Justin.
Comment 3 Justin Piszcz 2011-07-02 01:51:44 UTC
Hello,

Please ignore all my bug reports concerning kernel crashes for the past
3-4 weeks, my PSU from 2008 failed, I replaced it and my system is back up
and running, I'm sure it will be fine now.

I'll also update the bugzilla entry, for 2.6.38->2.6.39.

Thanks,

Justin.
Comment 4 Justin Piszcz 2011-07-02 01:52:05 UTC
This can be closed.
Comment 5 Rafael J. Wysocki 2011-07-02 12:41:59 UTC
Assuming fixed.

Note You need to log in before you can comment on or make changes to this bug.