Bug 3662 - HDD problems when waking from S3 in Acer Aspire 1314
Summary: HDD problems when waking from S3 in Acer Aspire 1314
Status: REJECTED DUPLICATE of bug 2039
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Shaohua
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-29 10:34 UTC by Albert Vilella
Modified: 2005-12-22 20:47 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.8-1.521
Tree: Mainline
Regression: ---


Attachments
dmidecode log (9.54 KB, text/plain)
2004-10-29 10:36 UTC, Albert Vilella
Details
lspci -vvv (8.69 KB, text/plain)
2004-10-29 10:44 UTC, Albert Vilella
Details
acpi dump (18.04 KB, application/x-unknown-application-x-gzip)
2004-10-30 13:09 UTC, Albert Vilella
Details
interrupts log (547 bytes, text/plain)
2004-10-30 13:11 UTC, Albert Vilella
Details
dmesg -s40000 (12.93 KB, text/plain)
2004-10-31 01:17 UTC, Albert Vilella
Details
dsdt.asl.gz (9.86 KB, application/x-unknown-application-x-gzip)
2004-10-31 02:11 UTC, Albert Vilella
Details
original dsdl.dsl obtained with AML Dissasembler version 20050211 (90.92 KB, text/x-dsl)
2005-02-26 15:03 UTC, Albert Vilella
Details
recompiled DSDT.aml (11.60 KB, application/octet-stream)
2005-02-26 15:09 UTC, Albert Vilella
Details
recompiled dsdt.hex (109.05 KB, application/octet-stream)
2005-02-26 15:10 UTC, Albert Vilella
Details

Description Albert Vilella 2004-10-29 10:34:19 UTC
Distribution: Fedora Core 2
Hardware Environment: Acer Aspire 1314
Software Environment: Fedora Core 2 with official 2.6.8-1.521 version from Fedora
Problem Description: 

Problem Description: Suspend to RAM fails when I try to do a echo 3 >
/proc/acpi/sleep in my notebook. Shuts X correctly, normally and really fast (1
or 2 seconds), all the hardware sleeping, the power indicator LED goes blinking.
But, when I press the "Power" key in my keyboard, X session restores ok,
keyboard and mouse input ok, all fine but the HDD seems to have trouble
recovering (HDD led blinking hard), can't execute any command because the hdd is
not accessible. Kernel outputs DMA timeouts for the hdd...  After half a minute,
decides it can't restore, and goes for a controlled shutdown.
 
Steps to reproduce: Go "suspend" to S3. It goes to sleep mode, the power LED 
blinks. If I press the power button, it restores graphics, keyboard and mouse 
are working but HDD has problems.
Comment 1 Albert Vilella 2004-10-29 10:35:11 UTC
I know this is the same than http://bugme.osdl.org/show_bug.cgi?id=2039
but happens with 2.6.8-1.521.
Comment 2 Albert Vilella 2004-10-29 10:36:15 UTC
Created attachment 3901 [details]
dmidecode log

dmidecode log. How do I create an acpi.dump?
Comment 3 Albert Vilella 2004-10-29 10:44:29 UTC
Created attachment 3902 [details]
lspci -vvv

lspci -vvv of the Acer Aspire 1314
Comment 4 Albert Vilella 2004-10-30 13:09:03 UTC
Created attachment 3916 [details]
acpi dump
Comment 5 Albert Vilella 2004-10-30 13:11:52 UTC
Created attachment 3917 [details]
interrupts log
Comment 6 Albert Vilella 2004-10-31 01:17:06 UTC
Created attachment 3918 [details]
dmesg -s40000
Comment 7 Albert Vilella 2004-10-31 02:11:21 UTC
Created attachment 3919 [details]
dsdt.asl.gz
Comment 8 Albert Vilella 2004-11-16 08:18:17 UTC
Still happens with stock FC3 kernel: 2.6.9-1.667
Comment 9 Albert Vilella 2005-01-11 01:07:48 UTC
Still happening with 2.6.10 FC3 kernel:

Linux magneto 2.6.10-1.737_FC3 #1 Mon Jan 10 13:50:10 EST 2005 i686 athlon i386
GNU/Linux

Now it locks up with half of gnome interface reloaded: no mouse, no keyboard,
even trying to controlled shutdown with power button fails. Had to force
shutdown by pressing the power button for 2-3 seconds (power shutdown).
Comment 10 Albert Vilella 2005-02-26 15:03:29 UTC
Created attachment 4604 [details]
original dsdl.dsl obtained with AML Dissasembler version 20050211
Comment 11 Albert Vilella 2005-02-26 15:09:53 UTC
Created attachment 4605 [details]
recompiled DSDT.aml

[suspend_to_ram]# ./acpica-unix-20050211/compiler/iasl -tc dsdt.dsl

Intel ACPI Component Architecture
ASL Optimizing Compiler / AML Disassembler version 20050211 [Feb 26 2005]
Copyright (C) 2000 - 2005 Intel Corporation
Supports ACPI Specification Revision 3.0

ASL Input:  dsdt.dsl - 2834 lines, 93103 bytes, 1282 keywords
AML Output: DSDT.aml - 11877 bytes 381 named objects 901 executable opcodes

Compilation complete. 0 Errors, 0 Warnings, 0 Remarks, 370 Optimizations
Comment 12 Albert Vilella 2005-02-26 15:10:49 UTC
Created attachment 4606 [details]
recompiled dsdt.hex

[suspend_to_ram]# ./acpica-unix-20050211/compiler/iasl -tc dsdt.dsl

Intel ACPI Component Architecture
ASL Optimizing Compiler / AML Disassembler version 20050211 [Feb 26 2005]
Copyright (C) 2000 - 2005 Intel Corporation
Supports ACPI Specification Revision 3.0

ASL Input:  dsdt.dsl - 2834 lines, 93103 bytes, 1282 keywords
AML Output: DSDT.aml - 11877 bytes 381 named objects 901 executable opcodes

Compilation complete. 0 Errors, 0 Warnings, 0 Remarks, 370 Optimizations
Comment 13 Albert Vilella 2005-07-06 10:13:04 UTC
Apparently, Linux currently has no real support for setting up IDE interfaces on
resume. Some machines are kind enough to set the IDE interface up themselves,
but on others the HD won't recover. So I suppose this bug should be assigned to
IDE people...
Comment 14 Albert Vilella 2005-07-06 10:22:32 UTC
My bug report in redhat bug tracker was already sent upstream by Alan Cox:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=155102

So I suppose that means it already is in the "to do" list in the upstream bug
tracker... (kernel?)
Comment 15 Shaohua 2005-11-08 19:59:05 UTC
Could you please try the patch at bug 2039 and report it back? Let's see if 
the ide failure is caused by lack of invoking ACPI metthods.
Comment 16 Shaohua 2005-12-22 20:47:05 UTC

*** This bug has been marked as a duplicate of 2039 ***

Note You need to log in before you can comment on or make changes to this bug.