Bug 36482 - Resume from hibernate unreliable on samsung sf510
Resume from hibernate unreliable on samsung sf510
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2011-06-01 20:36 UTC by Patrick
Modified: 2012-01-18 05:18 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.38
Tree: Mainline
Regression: No


Attachments
Old bug report on launchpad that might contain relevant information (59 bytes, text/plain)
2011-06-01 20:37 UTC, Patrick
Details
A dmesg after an unsucessful hibernation attemt - could be unrelated (107.45 KB, text/plain)
2011-06-01 20:41 UTC, Patrick
Details
A dmesg after an unsucessful resume - no idea how I landed in that busybox shell from where I saved it ... (66.17 KB, text/plain)
2011-06-01 20:42 UTC, Patrick
Details
screenshot after unsuccessful resume, with Xorg running, after hibernate from vt1 (370.32 KB, image/jpeg)
2011-06-01 20:49 UTC, Patrick
Details
screenshot after unsuccessful resume, with Xorg NOT running, after hibernate from vt1 (384.26 KB, image/jpeg)
2011-06-01 20:53 UTC, Patrick
Details
dmesg of successful hibernate / resume (67.64 KB, text/plain)
2011-06-11 13:19 UTC, Patrick
Details
dmesg of successful suspend-to-ram / resume (continuation of the last one) (15.61 KB, text/plain)
2011-06-11 13:37 UTC, Patrick
Details
dmesg of successful hibernate / resume (including unrelated cfg80211 log spam) (116.08 KB, text/plain)
2011-06-11 13:46 UTC, Patrick
Details

Description Patrick 2011-06-01 20:36:13 UTC
Resume from hibernate works only 40% of times.

At other times the laptop freezes completely.

In some cases it can be rebootet with Alt-SysReq b.

I have tried to collect some screenshots and dmesg outputs but I don't manage to make much sense of the information because I can't find any pattern.

I am currently running stock ubuntu natty amd64.

I will attach everything I have so far and am willing to try vanilla kernels, apply patches or whatever is required to get to the root of this. I'd just need some directions from an expert.
Comment 1 Patrick 2011-06-01 20:37:53 UTC
Created attachment 60452 [details]
Old bug report on launchpad that might contain relevant information

Have a look at the screenshot in comment #5
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/757921/comments/5
Comment 2 Patrick 2011-06-01 20:41:11 UTC
Created attachment 60462 [details]
A dmesg after an unsucessful hibernation attemt - could be unrelated
Comment 3 Patrick 2011-06-01 20:42:42 UTC
Created attachment 60472 [details]
A dmesg after an unsucessful resume - no idea how I landed in that busybox shell from where I saved it ...
Comment 4 Patrick 2011-06-01 20:49:14 UTC
Created attachment 60482 [details]
screenshot after unsuccessful resume, with Xorg running, after hibernate from vt1
Comment 5 Patrick 2011-06-01 20:53:15 UTC
Created attachment 60492 [details]
screenshot after unsuccessful resume, with Xorg NOT running, after hibernate from vt1

This is probably the most valueable screenshot. When resuming, this time, after the ram image was loaded from the hd, several oops messages appeared on the screen. They came in ~3 series of ~~5 oops messages and with pauses of ~1s in between each bunch. This is a screenshot of the last message seen. I could still switch vts and reboot with Alt-SysReq b here.
Comment 6 Len Brown 2011-06-07 02:11:20 UTC
does the problem go away if "maxcpus=1" is always used?

does suspend to ram work any better?

please attach the dmesg from a SUCCESSFUL hibernate/resume.
Comment 7 Patrick 2011-06-11 13:19:24 UTC
Created attachment 61582 [details]
dmesg of successful hibernate / resume

this succeeded, even though i had a second monitor connected to hdmi output during resume (the external monitor is "causing trouble" for other resons then hibernate/resume as well, like closing the laptop lid... but that's a different bug)
Comment 8 Patrick 2011-06-11 13:37:20 UTC
Created attachment 61592 [details]
dmesg of successful suspend-to-ram / resume (continuation of the last one)

suspend to ram tends to work, generally, for as far as the kernel is concerned, at least.

the x server / driver / compiz / unity quartet is sometimes cousing trouble though which i think could be related to suspend/resume (maybe): the x session tends to lock up after 2 or 3 suspend/resume cycles. first, the screen is not beeing properly updated, e.g. some windows are visible but not responsing to mouse/keyboard input. sometimes the screensaver unlock dialog is not visible, etc. - finally i loose patience and hard-switch it off. but this, as said, are actually different issues, i guess

next, i will boot and test with maxcpus=1 ...
Comment 9 Patrick 2011-06-11 13:46:47 UTC
Created attachment 61602 [details]
dmesg of successful hibernate / resume (including unrelated cfg80211 log spam)

attachment id 61582: "dmesg of successful hibernate / resume" is filtered with
$ dmesg | egrep cfg80211:\|wlan0:\|Associated:
because i think those lines are superfluous but here is the original dmesg output just in case i'm wrong
Comment 10 Patrick 2011-06-11 14:58:23 UTC
No, maxcpus=1 doesn't have any noticeable effects.

First it worked once. Then failed on the second try. After that I booted again, tried to hibernate: Failure because of firefox-bin "refusing to freeze after 20 seconds" or something along that line. Tried again. Hibernated. Booting (always using maxcpus=1), failure. No signs of x any more. No possibility to get a text console. Ctrl-Alt-F1 not showing any effect. Alt-SysReq-{s,u,b} - reboot. Last try, again maxcpus=1. (It's working, there is only one cpu e.g. in htop) Hibernate. Success onn first try. Reboot - maxcpus=1 - failure. Managed to switch to vt1 somehow by pressing Ctrl-Alt-F1 at the right time. Now, the "tty1" login prompt was visible with cursor blinking but no letters appearing when trying to type my login. Switching to tty2 works - "tty2" login prompt visible, but same problem: can't type my login name - no response to letter keys and no response to return key. Out of ideas. Alt-SysRq-{s,u,b}. Reboot.

Any other ideas ?
Comment 11 Patrick 2011-06-11 15:03:02 UTC
So the funny thing after the last unsuccessful resume was that I could switch between tty1-6 but at the same time couldn't type anything to the "Login: _" - even though the cursor was blinking and the process waiting for input there. ... When i finally tried to switch back to X with Ctrl-Alt-F7, the screen just went black and I couldn't swich back any more. Then I rebooted with Alt-SysRq-b...
Comment 12 Patrick 2012-01-14 12:24:51 UTC
This bug is fixed in 3.2.1

Hibernate / Resume and Suspend / Wakeup work reliably and fast.

Somebody with the proper permissions could set the appropriate status.
Comment 13 Zhang Rui 2012-01-18 05:18:45 UTC
(In reply to comment #12)
> This bug is fixed in 3.2.1
> 
> Hibernate / Resume and Suspend / Wakeup work reliably and fast.
> 
> Somebody with the proper permissions could set the appropriate status.

Good to know. Bug closed. :)

Note You need to log in before you can comment on or make changes to this bug.