Bug 3643 - LAPIC-mode poweroff on Dell D600
LAPIC-mode poweroff on Dell D600
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Power-Off
i386 Linux
: P2 normal
Assigned To: acpi_power-off
:
: 1355 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-26 00:37 UTC by Alexey Starikovskiy
Modified: 2004-12-05 19:38 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.9
Tree: Mainline
Regression: ---


Attachments
Patch to shutdown LAPIC at poweroff (938 bytes, patch)
2004-10-26 00:40 UTC, Alexey Starikovskiy
Details | Diff
Shutdown LAPIC at poweroff (1.80 KB, patch)
2004-11-09 00:42 UTC, Alexey Starikovskiy
Details | Diff
updated patch, vs. 2.6.9 (2.46 KB, patch)
2004-12-01 11:04 UTC, Len Brown
Details | Diff

Description Alexey Starikovskiy 2004-10-26 00:37:46 UTC
Distribution:
Hardware Environment: Dell Latitude D600
Software Environment:
Problem Description: No poweroff with both ACPI and LAPIC enabled

Steps to reproduce:
Comment 1 Alexey Starikovskiy 2004-10-26 00:40:06 UTC
Created attachment 3890 [details]
Patch to shutdown LAPIC at poweroff
Comment 2 Len Brown 2004-11-05 22:16:23 UTC

*** This bug has been marked as a duplicate of 3238 ***
Comment 3 Alexey Starikovskiy 2004-11-09 00:42:06 UTC
Created attachment 3995 [details]
Shutdown LAPIC at poweroff
Comment 4 Len Brown 2004-11-09 00:59:53 UTC
applied to 2.6.10 acpi-test tree
Comment 5 Len Brown 2004-11-10 18:01:37 UTC
*** Bug 1355 has been marked as a duplicate of this bug. ***
Comment 6 Len Brown 2004-12-01 11:04:13 UTC
Created attachment 4187 [details]
updated patch, vs. 2.6.9

The previous patch disabled the LAPIC too early on SMP machines.
This updated patch, suggested by Ingo Molnar, does it later.

Also, the previous patch disabled the LAPIC if it was enabled,
while this patch disables it only if Linux forced it to be enabled.
Comment 7 Len Brown 2004-12-01 11:06:37 UTC
reverted 1st patch and applied 2nd patch to acpi 2.6.10 test tree. 
Comment 8 Len Brown 2004-12-05 19:38:31 UTC
shipped in 2.6.10-rc3. 
closing 

Note You need to log in before you can comment on or make changes to this bug.