Bug 36392 - 2.6.39, 3.0-rc2 Intel DRI Regression: Black Screen after trying to play video
2.6.39, 3.0-rc2 Intel DRI Regression: Black Screen after trying to play video
Status: CLOSED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 high
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-06-01 04:41 UTC by Dennis Jansen
Modified: 2011-08-04 19:44 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.39,3.0-rc3
Tree: Mainline
Regression: Yes


Attachments
xorg log (19.07 KB, text/plain)
2011-06-01 04:42 UTC, Dennis Jansen
Details
/var/log/messages excerpt (265.03 KB, text/plain)
2011-06-01 04:43 UTC, Dennis Jansen
Details
error_state second recorded crash (768.85 KB, text/plain)
2011-06-09 17:56 UTC, Dennis Jansen
Details
second crash xorg.log (19.07 KB, text/plain)
2011-06-09 17:59 UTC, Dennis Jansen
Details
3: error_state (760.93 KB, text/plain)
2011-06-11 06:17 UTC, Dennis Jansen
Details
4: error_state in 3.0-rc2 (762.93 KB, text/plain)
2011-06-11 06:17 UTC, Dennis Jansen
Details
4: xorg.log in 3.0-rc2 (19.06 KB, text/plain)
2011-06-11 06:18 UTC, Dennis Jansen
Details
4: dmesg in 3.0-rc2 (122.54 KB, text/plain)
2011-06-11 06:19 UTC, Dennis Jansen
Details
5: var/log/messages in 3.0-rc3 (153.56 KB, text/plain)
2011-06-19 06:19 UTC, Dennis Jansen
Details

Description Dennis Jansen 2011-06-01 04:41:57 UTC
It hangs, then the screen is black with backlight on, then backlight turns off. The system still responds then but no screen. Dmesg and xorg log to follow.

[drm] capturing error event; look for more information in /debug/dri/0/i915_error_state
Jun  1 06:28:46 notebook kernel: [35653.482419] [drm] Changing LVDS panel from (+hsync, +vsync) to (-hsync, -vsync)
Jun  1 06:28:46 notebook kernel: [35653.482574] ------------[ cut here ]------------
Jun  1 06:28:46 notebook kernel: [35653.482617] WARNING: at /home/kernel-ppa/COD/linux/drivers/gpu/drm/i915/intel_display.c:1079 assert_pll+0xc3/0xd0 [i915]()
Jun  1 06:28:46 notebook kernel: [35653.482621] Hardware name: Extensa 5220                   
Jun  1 06:28:46 notebook kernel: [35653.482623] PLL state assertion failure (expected on, current off)
Jun  1 06:28:46 notebook kernel: [35653.482626] Modules linked in: nls_iso8859_1 nls_cp437 vfat fat isofs usb_storage uas autofs4 binfmt_misc ppdev deflate zlib_deflate ctr twofish_generic twofish_i586 twofish_common camellia serpent blowfish cast5 des_generic cryptd aes_i586 aes_generic xcbc rmd160 sha512_generic sha256_generic sha1_generic crypto_null af_key snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_seq_midi arc4 snd_rawmidi snd_seq_midi_event iwlagn snd_seq joydev mac80211 usbserial snd_timer snd_seq_device pcmcia cfg80211 snd ati_remote2 tifm_7xx1 nsc_ircc soundcore psmouse snd_page_alloc irda tifm_core yenta_socket crc_ccitt pcmcia_rsrc pcmcia_core sdhci_pci sdhci serio_raw acer_wmi sparse_keymap lp parport usbhid hid ahci libahci tg3 i915 drm_kms_helper drm i2c_algo_bit video
Jun  1 06:28:46 notebook kernel: [35653.482690] Pid: 18737, comm: kworker/u:31 Not tainted 2.6.39-020639-generic #201105190911
Jun  1 06:28:46 notebook kernel: [35653.482693] Call Trace:
Jun  1 06:28:46 notebook kernel: [35653.482723]  [<f82d7d83>] ? assert_pll+0xc3/0xd0 [i915]
Jun  1 06:28:46 notebook kernel: [35653.482737]  [<c104ffd1>] warn_slowpath_common+0x81/0xa0
Jun  1 06:28:46 notebook kernel: [35653.482768]  [<f82d7d83>] ? assert_pll+0xc3/0xd0 [i915]
Jun  1 06:28:46 notebook kernel: [35653.482778]  [<c1050093>] warn_slowpath_fmt+0x33/0x40
Jun  1 06:28:46 notebook kernel: [35653.482809]  [<f82d7d83>] assert_pll+0xc3/0xd0 [i915]
Jun  1 06:28:46 notebook kernel: [35653.482859]  [<f82d9ead>] intel_enable_pipe+0x3d/0x160 [i915]
Jun  1 06:28:46 notebook kernel: [35653.482897]  [<f82e64e7>] intel_crtc_mode_set+0xc27/0x2960 [i915]
Jun  1 06:28:46 notebook kernel: [35653.482931]  [<f82b25af>] ? i915_get_crtc_scanoutpos+0x4f/0x360 [i915]
Jun  1 06:28:46 notebook kernel: [35653.482937]  [<c1078500>] ? getnstimeofday+0x50/0x110
Jun  1 06:28:46 notebook kernel: [35653.482941]  [<c1078616>] ? do_gettimeofday+0x16/0x40
Jun  1 06:28:46 notebook kernel: [35653.482971]  [<f8054184>] ? drm_calc_vbltimestamp_from_scanoutpos+0x3b4/0x3e0 [drm]
Jun  1 06:28:46 notebook kernel: [35653.482991]  [<c128313d>] ? format_decode+0x2fd/0x360
Jun  1 06:28:46 notebook kernel: [35653.482996]  [<c1328150>] ? register_con_driver+0x170/0x170
Jun  1 06:28:46 notebook kernel: [35653.483001]  [<c1050447>] ? __call_console_drivers+0x77/0x90
Jun  1 06:28:46 notebook kernel: [35653.483043]  [<f82e147e>] ? i8xx_enable_fbc+0x1ee/0x3d0 [i915]
Jun  1 06:28:46 notebook kernel: [35653.483086]  [<f82e9fe5>] ? i965_update_wm+0x165/0x430 [i915]
Jun  1 06:28:46 notebook kernel: [35653.483111]  [<f8114108>] drm_crtc_helper_set_mode+0x298/0x410 [drm_kms_helper]
Jun  1 06:28:46 notebook kernel: [35653.483122]  [<c1528d0f>] ? _raw_spin_lock_irqsave+0x2f/0x50
Jun  1 06:28:46 notebook kernel: [35653.483143]  [<f8114764>] drm_helper_resume_force_mode+0x84/0x130 [drm_kms_helper]
Jun  1 06:28:46 notebook kernel: [35653.483171]  [<f82aae83>] i915_reset+0x193/0x210 [i915]
Jun  1 06:28:46 notebook kernel: [35653.483329]  [<f82af4fc>] i915_error_work_func+0xac/0xf0 [i915]
Jun  1 06:28:46 notebook kernel: [35653.483360]  [<c106806a>] process_one_work+0xda/0x340
Jun  1 06:28:46 notebook kernel: [35653.483383]  [<f82af450>] ? i915_get_vblank_timestamp+0xb0/0xb0 [i915]
Jun  1 06:28:46 notebook kernel: [35653.483388]  [<c1069883>] worker_thread+0xb3/0x210
Jun  1 06:28:46 notebook kernel: [35653.483392]  [<c10697d0>] ? manage_workers+0x90/0x90
Jun  1 06:28:46 notebook kernel: [35653.483396]  [<c106d465>] kthread+0x75/0x80
Jun  1 06:28:46 notebook kernel: [35653.483401]  [<c106d3f0>] ? kthread_bind+0x80/0x80
Jun  1 06:28:46 notebook kernel: [35653.483406]  [<c15305be>] kernel_thread_helper+0x6/0x10
Jun  1 06:28:46 notebook kernel: [35653.483409] ---[ end trace 17dfbc8d86d40af6 ]---
Jun  1 06:28:46 notebook kernel: [35653.592134] ------------[ cut here ]------------
Comment 1 Dennis Jansen 2011-06-01 04:42:24 UTC
Created attachment 60332 [details]
xorg log
Comment 2 Dennis Jansen 2011-06-01 04:43:13 UTC
Created attachment 60342 [details]
/var/log/messages excerpt

The "dmesg" is quite long. A lot is happening at the end.
Comment 3 Andrew Morton 2011-06-08 20:03:53 UTC
I assume that 2.6.38 was OK, and that this is a 2.6.38->2.6.39 regression?
Comment 4 Dennis Jansen 2011-06-09 09:35:39 UTC
Yes, this is a .38->.39 regression. There was a different bug in .38, though, more rare, but also related to a black screen (https://bugzilla.kernel.org/show_bug.cgi?id=27312#c8).
Comment 5 Dennis Jansen 2011-06-09 17:56:16 UTC
Created attachment 61372 [details]
error_state second recorded crash

I've logged the error state from debug/dri this time.
Comment 6 Dennis Jansen 2011-06-09 17:59:27 UTC
Created attachment 61382 [details]
second crash xorg.log

btw. This time the backlight didn't turn off, no idea why. And I see lots of iwlagn problems in demsg. let me know if you want the full and I'll extract it from /var/log
Comment 7 Dennis Jansen 2011-06-11 06:16:26 UTC
Still there in 3.0-rc2
Comment 8 Dennis Jansen 2011-06-11 06:17:06 UTC
Created attachment 61542 [details]
3: error_state
Comment 9 Dennis Jansen 2011-06-11 06:17:36 UTC
Created attachment 61552 [details]
4: error_state in 3.0-rc2
Comment 10 Dennis Jansen 2011-06-11 06:18:13 UTC
Created attachment 61562 [details]
4: xorg.log in 3.0-rc2
Comment 11 Dennis Jansen 2011-06-11 06:19:49 UTC
Created attachment 61572 [details]
4: dmesg in 3.0-rc2

By the way: The backlight doesn't turn off (anymore?). (Maybe I confused that with the other bug?)

And it always happened with mplayer, never with flash video.
Comment 12 Dennis Jansen 2011-06-11 11:48:48 UTC
Ok, it's actually much worse now, it crashes really hard on VT switch between X and console sometimes now. I can't say any more than that because it's a bit harder to reproduce and its a very hard freeze: no reisub, no response in any way. wifi still blinking but otherwise unresponsive. And as a make was going on, I had to replace the entire source tree because several files were cut off somewhere or filled with junk data.
Comment 13 Dennis Jansen 2011-06-11 13:40:20 UTC
this might be related to 
"[drm:drm_mode_getfb] *ERROR* invalid framebuffer id"
which shows up each time I switch out of X and back in.
Comment 14 Rafael J. Wysocki 2011-06-13 17:22:38 UTC
On Monday, June 13, 2011, Dennis Jansen wrote:
> On Sun, Jun 12, 2011 at 11:12 PM, Rafael J. Wysocki <rjw@sisk.pl> wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.38 and 2.6.39.
> >
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.38 and 2.6.39.  Please verify if it still should
> > be listed and let the tracking team know (either way).
> 
> Yes it should. And there's nobody actively working on it yet it seems.
> >
> >
> > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=36392
> > Subject         : 2.6.39, 3.0-rc2 Intel DRI Regression: Black Screen after trying to play video
> > Submitter       : Dennis Jansen <dennis.jansen@web.de>
> > Date            : 2011-06-01 04:41 (12 days old)
Comment 15 Dennis Jansen 2011-06-15 18:58:55 UTC
On Wed, Jun 15, 2011 at 8:52 PM, Jesse Barnes <jbarnes@virtuousgeek.org> wrote:
> On Sun, 12 Jun 2011 23:12:11 +0200 (CEST)
> "Rafael J. Wysocki" <rjw@sisk.pl> wrote:
>
>> This message has been generated automatically as a part of a report
>> of regressions introduced between 2.6.38 and 2.6.39.
>>
>> The following bug entry is on the current list of known regressions
>> introduced between 2.6.38 and 2.6.39.  Please verify if it still should
>> be listed and let the tracking team know (either way).
>>
>>
>> Bug-Entry     : http://bugzilla.kernel.org/show_bug.cgi?id=36392
>> Subject               : 2.6.39, 3.0-rc2 Intel DRI Regression: Black Screen after trying to play video
>> Submitter     : Dennis Jansen <dennis.jansen@web.de>
>> Date          : 2011-06-01 04:41 (12 days old)
>
> Did you ever bisect this issue?
>
> --
> Jesse Barnes, Intel Open Source Technology Center
>


No. Do you mean the black screen or the framebuffer id error? Because the black screen problem is not really bisectable. I don't know how exactly to provoke it. It doesn't happen immediately after boot, but after at least a day or so and one or more suspends I think. And not knowing what exactly is need to provoke it, it would take *quite a while* to get there. I'm currently trying -rc3 to see if things have improved.
Comment 16 Chris Wilson 2011-06-15 19:14:12 UTC
The GPU hang is due to the broken xf86-video-intel DDX. The blank screen is due to failed reset on the chip. The "invalid framebuffer id" error is relatively harmless and due to a silly Ubuntu patch.
Comment 17 Dennis Jansen 2011-06-16 21:24:56 UTC
I think this is fixed in 3.0-rc3.
Comment 18 Dennis Jansen 2011-06-19 06:13:12 UTC
No, it wasn't. It took longer this time than before. But that could just be random of course.
Comment 19 Dennis Jansen 2011-06-19 06:19:02 UTC
Created attachment 62752 [details]
5: var/log/messages in 3.0-rc3

attachded messages from 3.0-rc3.
First you see resume from standby, then the crash, then a new clean boot.
As always, it happened when trying to playback a video.
Comment 20 Dennis Jansen 2011-06-19 06:46:46 UTC
So Chris, are you saying that the crash is due to the driver being "too old"?

If so, is this a Won't fix? Do I have to upgrade my distribution or at least X driver to use and keep testing new releases?
Comment 21 Dennis Jansen 2011-07-26 08:35:58 UTC
I haven't noticed this anymore after the last -rc upgrade. Hoping it's not just accident or less frequent, I'm closing the bug.
Comment 22 Florian Mickler 2011-08-04 19:44:25 UTC
Thanks for following up on this. 
If the fix is not known, we better close it as unreproducible. 

Regards,
Flo

Note You need to log in before you can comment on or make changes to this bug.