Bug 36332 - Intel gpu turns external monitor off when X starts
Intel gpu turns external monitor off when X starts
Status: CLOSED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-05-31 02:53 UTC by rocko
Modified: 2012-03-25 18:42 UTC (History)
5 users (show)

See Also:
Kernel Version: 3.0-rc1
Tree: Mainline
Regression: Yes


Attachments

Description rocko 2011-05-31 02:53:53 UTC
When I boot my XPS 15 L502x laptop (with i7-2630QM Sandy Bridge) with kernel 3.0-rc1, the external monitor connected via the mini-displayport initially powers on during the Ubuntu 11.04 startup splash screen, but turns off when gdm-greeter appears. 

It remains off. However, xrandr thinks that it is turned on:

HDMI1 connected 1680x1050+1920+0 (normal left inverted right x axis y axis) 473mm x 296mm
   1680x1050      59.9*+

and xorg.conf shows that it correctly identifies the screen, etc. (Note that the display is connected via a mini-displayport-to-HDMI adapter and it shows up as HDMI1, not DP1.)

If I wait until the laptop screen blanks (via DPMS) and then hit a key to bring it back, the external display powers up. I can also power it up by manually forcing it off and back on again, eg with:

xrandr --output HDMI1 --off
xrandr --output HDMI1 --right-of LVDS1 --auto

The same bug shows up in 2.6.39 but not in 2.6.38, where it stays powered on when gdm starts up, so the original regression was in 2.6.39.
Comment 1 rocko 2011-06-12 23:14:47 UTC
It still happens in 3.0-rc2 - the external monitor powers down as soon as gdm-greeter runs. However, since I updated the X drivers using the xorg-edgers PPA, the external monitor powers back on after I login.
Comment 2 rocko 2011-06-16 01:50:51 UTC
I tried bisecting but I can't build the kernel (I get *** [drivers] Error 2 'debian/stamp/build/kernel Error 2' with no further information). So I tried the Ubuntu supplied weekly build kernels and got:

2.6.39-rc3: external monitor doesn't turn on

2.6.39-rc2: (no build available)

2.6.39-rc1: laptop display doesn't turn on (xrandr reports unknown connection) but external monitor does 

So all I know for sure is that it happened between 2.6.38 and 2.6.39-rc3. I suspect that the fact that the external monitor turned on in rc1 doesn't mean rc1 is OK because the external monitor at that point was the primary monitor.
Comment 3 Keith Packard 2011-08-09 15:06:25 UTC
I found some additional dual display issues on Sandy bridge and there are patches in my drm-intel-fixes tree.

Care to give this a try? It's based on 3.0-rc1

git://git.kernel.org/pub/scm/linux/kernel/git/keithp/linux-2.6 drm-intel-fixes
Comment 4 Keith Packard 2011-08-09 16:01:07 UTC
er, I mean 3.1-rc1, of course
Comment 5 rocko 2011-08-09 23:20:54 UTC
I cloned that repo and the external monitor stays on the whole time, but the laptop monitor turns off as soon as the kernel boots (xrandr says 'LVDS1 unknown connection').

This reminds me of an issue that happened early with 2.6.39, and indeed this kernel does identify itself as 2.6.39-rc1 and not 3.1-rc1. Did I do something wrong?
Comment 6 Keith Packard 2011-08-09 23:40:43 UTC
Yeah, you need to check out the drm-intel-fixes branch of that repo, not the master branch.
Comment 7 rocko 2011-08-10 02:02:28 UTC
Silly me! I blame it on the time (early morning).

Yes, the new drm-intel-fixes branch fixes the problem, thanks. The external monitor stays on throughout bootup and login, which is great as whatever patch caused the bug has been added to both 3.0.1 and the Ubuntu 2.6.38-11 kernel.
Comment 8 Florian Mickler 2012-03-25 18:42:26 UTC
Beeing a nitpicker here, since we don't have the sha1 of the fix, I change the resolution to unreproducible. 

I don't think this is a problem, since stable already fixed it, so we can leave it at that.

Note You need to log in before you can comment on or make changes to this bug.