Bug 3622 - S3 resume: no video - Dell Inspiron 510m
Summary: S3 resume: no video - Dell Inspiron 510m
Status: REJECTED DUPLICATE of bug 3670
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake (show other bugs)
Hardware: i386 Linux
: P2 high
Assignee: Venkatesh Pallipadi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-23 02:41 UTC by William Hanwoody
Modified: 2004-11-07 18:09 UTC (History)
0 users

See Also:
Kernel Version: 2.6.8.1 and 2.6.9
Tree: Mainline
Regression: ---


Attachments
dsdt for dell 510m A06 (91.93 KB, text/plain)
2004-10-27 21:56 UTC, William Hanwoody
Details

Description William Hanwoody 2004-10-23 02:41:40 UTC
Distribution:Debian Sid
Hardware Environment:
0000:00:00.0 Host bridge: Intel Corp. 82852/855GM Host Bridge (rev 02)
0000:00:00.1 System peripheral: Intel Corp. 855GM/GME GMCH Memory I/O Control
Registers (rev 02)
0000:00:00.3 System peripheral: Intel Corp. 855GM/GME GMCH Configuration Process
Registers (rev 02)0000:00:02.0 VGA compatible controller: Intel Corp.
82852/855GM Integrated Graphics Device (rev 02)0000:00:02.1 Display controller:
Intel Corp. 82852/855GM Integrated Graphics Device (rev 02)
0000:00:1d.0 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #1 (rev 01)
0000:00:1d.1 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #2 (rev 01)
0000:00:1d.2 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #3 (rev 01)
0000:00:1d.7 USB Controller: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB 2.0 EHCI
Controller (rev 01)0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 81)
0000:00:1f.0 ISA bridge: Intel Corp. 82801DBM LPC Interface Controller (rev 01)
0000:00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4) Ultra ATA Storage
Controller (rev 01)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
0000:00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem
Controller (rev 01)
0000:01:01.0 CardBus bridge: Texas Instruments PCI4510 PC card Cardbus
Controller (rev 02)
0000:01:01.1 FireWire (IEEE 1394): Texas Instruments PCI4510 IEEE-1394 Controller
0000:01:03.0 Network controller: Intel Corp. PRO/Wireless 2200BG (rev 05)
0000:01:08.0 Ethernet controller: Intel Corp. 82801BD PRO/100 VE (MOB) Ethernet
Controller (rev 81)
Software Environment:
X version:4.3
Problem Description:
When echo 3 > /proc/acpi/sleep,succeed in suspending.But when wakeing up,LCD
remains black,but others resumed ok. Another similar is:when I put down
LCD,screen becomes black automatically,but when I put up LCD,it cannot resume.
Steps to reproduce:
Comment 1 William Hanwoody 2004-10-27 21:56:36 UTC
Created attachment 3895 [details]
dsdt for dell 510m A06
Comment 2 Venkatesh Pallipadi 2004-10-28 06:28:25 UTC
Can you try out the acpi_sleep options from Documentation/power/video.txt
Comment 3 William Hanwoody 2004-10-31 04:58:29 UTC
I dont try it,and I look it in Documentation.But how to use it?

just add acpi_sleep=s3_mode to lilo.conf or grub's menu.lst?

but resuming from s3 dont need lilo or grub,not s4.
Comment 4 William Hanwoody 2004-10-31 05:31:49 UTC
I tried acpi_sleep=s3_mode and acpi_sleep=s3_bios in menu.lst of grub.But it is
so terrible that it is only restart machine!!so bad so bad,It cannot resume to
original state,then we want acpi_sleep option to do what??
Comment 5 Venkatesh Pallipadi 2004-11-03 18:52:44 UTC
Can you try the workaround in bug #3670
Comment 6 William Hanwoody 2004-11-07 17:48:15 UTC
see Bug 3670, this problem has been fixed.
Comment 7 Venkatesh Pallipadi 2004-11-07 18:09:58 UTC

*** This bug has been marked as a duplicate of 3670 ***

Note You need to log in before you can comment on or make changes to this bug.