Bug 36102 - Plug-in of USB HDD crashes system
Summary: Plug-in of USB HDD crashes system
Status: RESOLVED DUPLICATE of bug 36092
Alias: None
Product: IO/Storage
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 high
Assignee: io_other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-28 14:08 UTC by Arno Wagner
Modified: 2011-06-09 10:21 UTC (History)
0 users

See Also:
Kernel Version: 2.6.38.6 - 2.6.39.1
Tree: Mainline
Regression: No


Attachments
crash log (1.88 KB, application/octet-stream)
2011-05-28 14:08 UTC, Arno Wagner
Details
.config 2.6.38.6 (66.77 KB, application/octet-stream)
2011-05-28 14:09 UTC, Arno Wagner
Details
lspci (10.16 KB, application/octet-stream)
2011-05-28 14:09 UTC, Arno Wagner
Details
lsusb (22.24 KB, application/octet-stream)
2011-05-28 14:09 UTC, Arno Wagner
Details
csash log via serial (1.88 KB, text/plain)
2011-05-29 04:09 UTC, Arno Wagner
Details

Description Arno Wagner 2011-05-28 14:08:10 UTC
Created attachment 59802 [details]
crash log

It seems I messed up the first submission, so here goes again:

With kernels 2.6.38.6 - 2.6.39, plug-in of a specific WD Elements USB HDD (see crash log for details) crashes my system. Plugging the drive in is enough, takes a few seconds to lock up the filesystem and the rest of the system with it. With two other WD USB HDDs this does not happen, but these are earlier models.

Attached are
- crash log captured via serial console
- .config for 2.6.38.6
- lspci
- lsusb with the disk in question plugged in

If you need anything else, please let me know.
Comment 1 Arno Wagner 2011-05-28 14:09:16 UTC
Created attachment 59812 [details]
.config 2.6.38.6
Comment 2 Arno Wagner 2011-05-28 14:09:33 UTC
Created attachment 59822 [details]
lspci
Comment 3 Arno Wagner 2011-05-28 14:09:53 UTC
Created attachment 59832 [details]
lsusb
Comment 4 Arno Wagner 2011-05-29 04:09:06 UTC
Created attachment 59902 [details]
csash log via serial
Comment 5 Arno Wagner 2011-06-02 10:01:03 UTC
Yesterday I has a hard filesystem lockup that looked much the same as the issuse I reported here. This was on a different system with 2.6.38.5 after an UML instance running with user permission crashed. It seems there is some fundamental show-stopper in the filesystem code or the SMP code that causes hard system crashes and was introduced in 2.6.38.5 or before. The lockup on USB plugin in 2.6.38.6 and later may just be a symptom or a secondary effect. It can however serve as a valuable debugging aid, as it reliably causes the system to crash.

For the moment, I am back to 2.6.37.6, as I really cannot have my mail-server crash at random times. 

Is anybody looking at this? Hard filesystem crashes caused by software are something I did not have for a long, long time. Scary.

BTW, I know that these are hard filesystem crashes, as I observed software RAID1 partitions resyncing after reboot and had one instance of a file containing nonsense at the end (I had that open in an editor during the crash), where the ext3 log seems to already have contained the medadata but not the file data itself.
Comment 6 Arno Wagner 2011-06-06 16:00:05 UTC
Kernel 2.6.39.1: No change, still hard crash on plug-in of the specific WD USB disk.
Comment 7 Arno Wagner 2011-06-09 10:21:43 UTC
Due to bugzilla flakiness, this is a duplicate of my original submission. Marked as such.

*** This bug has been marked as a duplicate of bug 36092 ***

Note You need to log in before you can comment on or make changes to this bug.