Bug 35882 - iwlegacy - iwl4965 & 5GHZ Wireless N AP
iwlegacy - iwl4965 & 5GHZ Wireless N AP
Status: CLOSED CODE_FIX
Product: Networking
Classification: Unclassified
Component: Wireless
All Linux
: P1 normal
Assigned To: Stanislaw Gruszka
:
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-05-26 03:07 UTC by Greg
Modified: 2011-06-09 09:07 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.39
Tree: Mainline
Regression: Yes


Attachments
dmesg (58.67 KB, text/plain)
2011-05-26 03:07 UTC, Greg
Details
iwlist scanning - after boot (32.44 KB, text/plain)
2011-05-26 03:10 UTC, Greg
Details
iwlist scanning - after connection to N AP is successful (29.41 KB, text/plain)
2011-05-26 03:12 UTC, Greg
Details
dmesg (58.93 KB, text/plain)
2011-05-26 03:13 UTC, Greg
Details

Description Greg 2011-05-26 03:07:35 UTC
Created attachment 59472 [details]
dmesg

Since the driver moved to the iwlegacy folder, I've had problems. It works fine with 2.6.38.

Symptoms... it won't find the AP and associate with it until I've run iwlist scanning a number of times. If I wait, it sometimes eventually connects. I think this is because the gnome network manager is scanning in the background...

after the laptop boots, i log in and the network manager shows the 2.4GHZ APs that are in the area, but doesn't show my 5GHZ N AP.
Comment 1 Greg 2011-05-26 03:10:26 UTC
Created attachment 59482 [details]
iwlist scanning - after boot
Comment 2 Greg 2011-05-26 03:12:00 UTC
Created attachment 59492 [details]
iwlist scanning - after connection to N AP is successful
Comment 3 Greg 2011-05-26 03:13:03 UTC
Created attachment 59502 [details]
dmesg
Comment 4 Stanislaw Gruszka 2011-05-26 06:15:29 UTC
This patch (posted 2 days ago) should fix the problem:
http://marc.info/?l=linux-wireless&m=130624736119019&w=2
Comment 5 Greg 2011-05-26 12:45:10 UTC
i built a new kernel this morning with the above patch, and the wireless is now working perfectly :) Thanks!
Comment 6 Florian Mickler 2011-05-26 16:03:01 UTC
In order for Rafaels scripts to pick it up, we need it with a prefix:

Patch: http://marc.info/?l=linux-wireless&m=130624736119019&w=2
Comment 7 Greg 2011-06-03 02:18:30 UTC
will this be fixed in 3.0? I see it's missing from RC1 so far. thanks!
Comment 8 Stanislaw Gruszka 2011-06-03 13:20:28 UTC
It will. It take some time before patch propagate to Linus' tree.
Comment 9 Stanislaw Gruszka 2011-06-09 07:20:39 UTC
Patch is now applied:

commit aac11c1b351413aa3412e258e2b2dcba31777209
Author: Stanislaw Gruszka <sgruszka@redhat.com>
Date:   Tue May 24 16:28:55 2011 +0200

    iwl4965: fix 5GHz operation

Note You need to log in before you can comment on or make changes to this bug.