Bug 35582 - INITRAMFS crash
Summary: INITRAMFS crash
Status: RESOLVED OBSOLETE
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64 (show other bugs)
Hardware: All Linux
: P1 blocking
Assignee: platform_x86_64@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-21 23:03 UTC by js
Modified: 2013-12-23 13:33 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.39
Tree: Mainline
Regression: No


Attachments
kernel config (64.44 KB, application/octet-stream)
2011-05-21 23:03 UTC, js
Details
Screenshot of crash (23.84 KB, image/png)
2011-05-21 23:11 UTC, js
Details

Description js 2011-05-21 23:03:25 UTC
Created attachment 58942 [details]
kernel config

I have observed this behavior with all kernels since 2.6.27.54
If the initramfs is compiled into the kernel it will never boot.
If you boot from it as a separate initramfs file by passing it as an argument it does work.
Comment 1 js 2011-05-21 23:09:41 UTC
The actual message is: BUG: Bad page state in process swapper
Comment 2 js 2011-05-21 23:11:23 UTC
Created attachment 58952 [details]
Screenshot of crash

Note You need to log in before you can comment on or make changes to this bug.