Bug 35422 - [BISECTED] 2.6.39rc: kobject-related reboot after RAID array initialization(?) post-QUEUE_FLAG_REENTER-removal
[BISECTED] 2.6.39rc: kobject-related reboot after RAID array initialization(?...
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: MD
All Linux
: P1 normal
Assigned To: io_md
:
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-05-19 17:34 UTC by Maciej Rutecki
Modified: 2011-06-07 07:56 UTC (History)
4 users (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-05-19 17:34:17 UTC
Subject    : [BISECTED] 2.6.39rc: kobject-related reboot after RAID array initialization(?) post-QUEUE_FLAG_REENTER-removal
Submitter  : Nix <nix@esperi.org.uk>
Date       : 2011-05-15 22:05
Message-ID : 8762pboc0j.fsf@spindle.srvr.nix
References : http://marc.info/?l=linux-kernel&m=130549836609128&w=2

This entry is being used for tracking a regression from 2.6.38. Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit c21e6beba8835d09bb80e34961430b13e60381c5
Author: Jens Axboe <jaxboe@fusionio.com>
Date:   Tue Apr 19 13:32:46 2011 +0200

    block: get rid of QUEUE_FLAG_REENTER

    Signed-off-by: Jens Axboe <jaxboe@fusionio.com>

First-Bad-Commit : c21e6beba8835d09bb80e34961430b13e60381c5
Comment 1 Florian Mickler 2011-06-07 07:56:19 UTC
Patch: http://marc.info/?l=linux-kernel&m=130554213509304&w=2

commit 9937a5e2f32892db0dbeefc2b3bc74b3ae3ea9c7
Author: Jens Axboe <jaxboe@fusionio.com>
Date:   Tue May 17 11:04:44 2011 +0200

    scsi: remove performance regression due to async queue run

Note You need to log in before you can comment on or make changes to this bug.