Bug 35292 - early kernel crash when kmemleak is enabled
early kernel crash when kmemleak is enabled
Status: CLOSED CODE_FIX
Product: Other
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: other_other
:
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-05-17 19:10 UTC by Maciej Rutecki
Modified: 2011-06-06 21:12 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.39-rc4
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-05-17 19:10:33 UTC
Subject    : early kernel crash when kmemleak is enabled
Submitter  : Marcin Slusarz <marcin.slusarz@gmail.com>
Date       : 2011-05-15 10:55
Message-ID : 20110515105505.GA21631@joi.lan
References : http://marc.info/?l=linux-kernel&m=130545705511118&w=2

This entry is being used for tracking a regression from 2.6.38. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Florian Mickler 2011-06-06 21:12:05 UTC
Fixed by the following commit merged in 3.0-rc1:

commit 9b090f2da85bd0df5e1a1ecfe4120b7b50358f48
Author: Catalin Marinas <catalin.marinas@arm.com>
Date:   Thu May 19 16:25:30 2011 +0100

    kmemleak: Initialise kmemleak after debug_objects_mem_init()

Note You need to log in before you can comment on or make changes to this bug.