Bug 35272 - 2.6.38.6 -stable regression: kernel insta-death on boot.
2.6.38.6 -stable regression: kernel insta-death on boot.
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: platform_i386
:
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-05-17 18:48 UTC by Maciej Rutecki
Modified: 2011-06-12 20:43 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.38.6
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-05-17 18:48:49 UTC
Subject    : 2.6.38.6 -stable regression: kernel insta-death on boot.
Submitter  : Nick Bowler <nbowler@elliptictech.com>
Date       : 2011-05-14 19:57
Message-ID : 20110514195741.GA10757@elliptictech.com
References : http://marc.info/?l=linux-kernel&m=130541471818831&w=2

This entry is being used for tracking a regression from 2.6.38. Please don't
close it until the problem is fixed in the mainline.

Caused by:

  commit 15f0758f185241ad9c358a5bf60ff0a21eccc218
  Author: Boris Ostrovsky <ostr@amd64.org>
  Date:   Fri Apr 29 17:47:43 2011 -0400
  
      x86, AMD: Fix APIC timer erratum 400 affecting K8 Rev.A-E processors
       
      Reported-by: Joerg-Volker Peetz <jvpeetz@web.de>
      Tested-by: Joerg-Volker Peetz <jvpeetz@web.de>
      Acked-by: Borislav Petkov <borislav.petkov@amd.com>
      Signed-off-by: Boris Ostrovsky <Boris.Ostrovsky@amd.com>
      Link: http://lkml.kernel.org/r/1304113663-6586-1-git-send-email-ostr@amd64.org
      Signed-off-by: Ingo Molnar <mingo@elte.hu>
      Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>

First-Bad-Commit : 15f0758f185241ad9c358a5bf60ff0a21eccc218
Comment 1 Borislav Petkov 2011-05-18 14:14:53 UTC
Confirmation that the issue is fixed:

http://marc.info/?l=linux-kernel&m=130567145321467

Patches fixing it:

http://git.kernel.org/tip/14fb57dccb6e1defe9f89a66f548fcb24c374c1d
http://git.kernel.org/tip/328935e6348c6a7cb34798a68c326f4b8372e68a

I will backport them as soon as they hit mainline.

Thanks.
Comment 2 Ingo Molnar 2011-05-18 15:27:19 UTC
> I will backport them as soon as they hit mainline.

FYI, they are upstream already, Linus pulled them and pushed it out earlier 
today.

Thanks,

	Ingo

Note You need to log in before you can comment on or make changes to this bug.