Bug 35112 - Nuvoton CIR driver does not activate its LED monitor output
Summary: Nuvoton CIR driver does not activate its LED monitor output
Status: RESOLVED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: All Linux
: P1 enhancement
Assignee: drivers_input-devices
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-15 08:25 UTC by Bengt
Modified: 2013-12-23 12:11 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.38-8-generic
Tree: Mainline
Regression: No


Attachments

Description Bengt 2011-05-15 08:25:59 UTC
On my Intel DP55SB there is a Consumer Infra Red (CIR) header and a Nuvoton chip. The header has a CIR input and a LED output, and the LED should flash to indicate that a CIR command is successfully received. I have a receiver unit, with a IR-reciever chip and a LED indicator, connected to the header.

I can boot either Win7 or Ubuntu, and the CIR input itself is functioning well in both environments. In Ubuntu, I am using LIRC devinput.

However, I can see that when Win7 is used, the LED flashes as it should when I use the remote control, but when Ubuntu is used the LED is not flashing when I use the remote. 

Consequently, it must be a driver issue, and not hardware.

I propose that the nuvoton_cir driver should be updated so that the LED indicator signal works as intended.


BN
Comment 1 Li Jian 2012-08-10 05:49:32 UTC
Hi all, I am willing to fix this issue. I am asking Nuvoton for w836x7hg's spec and waiting for their response now.
Comment 2 Bengt 2012-08-10 06:01:26 UTC
Johnny,

Thanks for your effort, you now have the specs.

However, I suspect the driver needed will be motherboard-specific, which means there will not be a general solution to this problem.

I hope I am wrong.

BN

Note You need to log in before you can comment on or make changes to this bug.