Bug 35092 - invalid opcode in gpu/drm/drm_irq.c:923
Summary: invalid opcode in gpu/drm/drm_irq.c:923
Status: RESOLVED DUPLICATE of bug 37752
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: All Linux
: P1 blocking
Assignee: drivers_video-dri-intel@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-14 19:42 UTC by rbyshko
Modified: 2012-03-25 13:01 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.39-rc6-21-desktop
Tree: Mainline
Regression: No


Attachments
dmesg log, contains bug traces. (57.91 KB, text/plain)
2011-05-14 19:42 UTC, rbyshko
Details
lspci -vvv (24.00 KB, text/plain)
2011-05-14 19:45 UTC, rbyshko
Details

Description rbyshko 2011-05-14 19:42:22 UTC
Created attachment 57842 [details]
dmesg log, contains bug traces.

I've installed the newest kernel form opensuse kernel HEAD repository and try to boot in KDE environment. However, the sysem remains hanging on the KDE splashscreen.

I've logged in through ssh and collected all the information needed. The most interesting messages are in dmesg.txt I think.

Feel free to ask me additional info.

cat /proc/version
Linux version 2.6.39-rc6-21-desktop (geeko@buildhost) (gcc version 4.5.1 20101208 [gcc-4_5-branch revision 167585] (SUSE Linux) ) #1 SMP PREEMPT 2011-05-10 19:11:21 +0200
Comment 1 rbyshko 2011-05-14 19:45:41 UTC
Created attachment 57852 [details]
lspci -vvv
Comment 2 Daniel Vetter 2012-03-25 13:01:25 UTC
This smells like the pageflip race which got fixed with

commit 7317c75e66fce0c9f82fbe6f72f7e5256b315422
Author: Jesse Barnes <jbarnes@virtuousgeek.org>
Date:   Mon Aug 29 09:45:28 2011 -0700

    drm/i915: don't set unpin_work if vblank_get fails

Please upgrade to at least kernel 3.2. Please reopen if it's still broken.

*** This bug has been marked as a duplicate of bug 37752 ***

Note You need to log in before you can comment on or make changes to this bug.