Bug 34942 - [Bug] Kdump does not work when panic triggered due to MCE
[Bug] Kdump does not work when panic triggered due to MCE
Status: RESOLVED OBSOLETE
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: platform_i386
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-11 18:52 UTC by Maciej Rutecki
Modified: 2012-08-23 14:08 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.39-rc6
Tree: Mainline
Regression: No


Attachments

Description Maciej Rutecki 2011-05-11 18:52:14 UTC
Subject    : [Bug] Kdump does not work when panic triggered due to MCE
Submitter  : "K.Prasad" <prasad@linux.vnet.ibm.com>
Date       : 2011-05-06 16:54
Message-ID : 20110506165412.GB2719@in.ibm.com
References : http://marc.info/?l=linux-kernel&m=130470087226270&w=2

This entry is being used for tracking a regression from 2.6.38. Please don't
close it until the problem is fixed in the mainline.
Comment 1 K.Prasad 2011-07-11 06:00:46 UTC
I'm not sure if we can technically call this as a regression since kdump feature isn't working if the panic is triggered due to a fatal MCE, and the facility to inject MCEs were introduced in the kernel quite recently (the basic mce-inject.c file appears to have been introduced during v2.6.30 timeframe).

My report about kdump not working in http://marc.info/?l=linux-kernel&m=130470087226270&w=2, hasn't actually found out if it is broken since v2.6.30, so again we don't have enough information to qualify if it is a regression.

Given more time, I'd like to test the behaviour in kernel versions older than v2.6.38 and update the bug with details.

Let me know if more information is required.

Thanks,
K.Prasad
Comment 2 Florian Mickler 2011-08-08 19:17:14 UTC
Dropping from the list of regressions...

Note You need to log in before you can comment on or make changes to this bug.