Bug 34752 - [GM45] Screen located but not lid
Summary: [GM45] Screen located but not lid
Status: RESOLVED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri-intel@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-09 22:48 UTC by Rune Slettebakken
Modified: 2013-02-20 19:09 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.37
Tree: Mainline
Regression: No


Attachments

Description Rune Slettebakken 2011-05-09 22:48:02 UTC
When I try to boot into a freshly installed (or a live system) that uses kernel 2.6.38.X (and 2.6.37.X) my screen is located, but is not lid. Meaning that the screen turns black, but when I look VERY closely I can see the desktop appearing on the screen as "shadows".

I reckon this is an issue with the kernel, and not specific to any distro, as the problem is the same on both Ubuntu 11.04, OpenSUSE 11.4, Linux Mint 11RC and Debian Sid (When upgrading to kernel 2.6.38) 

My laptop is:
Acer Emachines E527
Cpu: T3300 Intel Celeron
grachics: Intel GMA 4500M on 15.6" HD LCD
Ram: 3 GB DDR3

Saw a similar bug was reported for a couple of nVidia and AMD systems, but not for Intel based systems. So thought I'd better report this problem. Really don't want to get stuck with kernel 2.6.35 (Which is the newest I've had success with on this system) for the rest of this laptop's lifetime.. :-)
Comment 1 Rune Slettebakken 2011-05-09 23:33:48 UTC
This is the information I get about my graphic card on my Linux Mint 10 -system:

Distribution:          Linux Mint 10
http://www.linuxmint.com/rel_julia.php
 Desktop environment:   GNOME
 Graphics chip:         Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)
 Driver in use:         intel
 Rendering method:      AIGLX
 (Which is working, but with a 2.6.35-22 kernel)
Comment 2 Daniel Vetter 2012-03-25 13:31:13 UTC
Smells like yet another acer with the inverted backlight: Please try the drm-intel-testing branch at

http://cgit.freedesktop.org/~danvet/drm-intel/

If that does not help, please attach the full output of

lspci -vmmn

so that we could try to add another quirk entry.
Comment 3 Jesse Barnes 2012-04-18 21:46:47 UTC
Assuming this is fixed now.  If not, please re-open and we'll add a quirk.
Comment 4 Rune Slettebakken 2012-04-19 19:42:07 UTC
Thanks for your replies.

Tried to boot Mageia 2 Beta 3 today, with kernel 3.3.1, and the problem is still the same. So then, it's a problem with the kernels from 2.6.37, and until the most recent ones. One frustrating, new issue, is that when trying to boot with the "safe settings" kernel mode, it didn't turn black, but stoppet with the message "No screens found".

I realise that it is diffucult to identify the problem without the "lspci -vmmn" output. But from a black screen, it isn't easy to read anything. (Please explain how, if you have any ideas of how to do that.)

Tried to find out how to test the drm-intel-testing branch, but yet again, I don't know how to install this on a system I'm unable to log into. (Due to black screen.) It was really difficult to find out which of the files, on that link, I should download, too. :-)

Since I'm probably not the only one with a computer with this issue, I'm really sorry that I don't have the skills to provide more help in solving this issue...
Comment 5 Jesse Barnes 2012-04-19 20:21:37 UTC
There's an #intel-gfx irc channel on irc.freenode.net you can use to ask for help; building the latest bits would be a good thing to test.

If you can, ssh into the machine blind to collect the info we'll need for the quirk, along with a register dump from intel_reg_dumper.
Comment 6 Jani Nikula 2013-01-08 14:33:01 UTC
Rune, is this still an issue? Any chance to attach the dmesg with drm.debug=0xe module parameter on a recent kernel, such as v3.7?
Comment 7 Rune Slettebakken 2013-01-08 22:00:37 UTC
Hi! And thanks for your patience.
I found out, very recently (december 30. 2012) that the issue now is solved, and the most recently kernels finally works again.
So I'm now running Linux Mint 14, 3.5.0-17generic, and it just works.
Has tested a few live systems after that, and it seems that something happened between version 3.4 and 3.5. Version 3.7 also seems to be working without this issue.
Comment 8 Jani Nikula 2013-01-09 07:58:13 UTC
Rune, thanks for replying. I am closing this as obsolete, as it now works for you, presumably due to some of the numerous fixes in out backlight handling, and debugging old kernel versions is not very productive.
Comment 9 thubten topgyal 2013-02-20 16:41:03 UTC
Intel GMA 4500M on 15.6" HD LCD
in acer travelmate 5735Z
screen is black after boot screen.
clearly a kernel 3.x problem.

since i-do-not-know-how-long i cannot install a new gnu/linux system of any kind (ubuntu, kubuntu, linux mint, whatever). i could solve the problem temporarily with workarounds as explained online, but this was not doable on the long-term (after updates or whatever happened, the screen turned black again), because the owners of these laptops are not knowledgeable and i cannot leave them with such a system. 

i am wondering whether within the lifetime of these laptops, gnu/linux will be unproblematic again. 

i am really sorry for having to wait for years on that issue. it must work out of the box, if i want to prove to people that they can easily use gnu/linux. now they are left with a system that is "no longer supported". 

today i tried ubuntu 12.04, kubuntu 12.04, linux mint 13 both in 32 bit and 64 bit versions. ---- it worked on a few other laptops (asus, lenovo, acer), but still not on the acer travelmates.

best wishes, topgyal
Comment 10 Daniel Vetter 2013-02-20 17:36:52 UTC
Thubten, can you please file a new bug report for your issue to avoid confusion?

Also please describe the workarounds which you've used to make things tempororily work, thanks.
Comment 11 thubten topgyal 2013-02-20 19:02:10 UTC
dear daniel 
thank you for this explanation; i am not sure how to do that, 
e.g., which category, etc.. -- well, i will try anyway.
best wishes, topgyal
Comment 12 Daniel Vetter 2013-02-20 19:09:40 UTC
> --- Comment #11 from thubten topgyal <thubtop@gmail.com>  2013-02-20 19:02:10
> ---
> dear daniel
> thank you for this explanation; i am not sure how to do that,
> e.g., which category, etc.. -- well, i will try anyway.
> best wishes, topgyal

Same as this bug here, i.e. DRI -> DRM(Intel) is a good starting point
to ensure we don't miss your bug. We'll then take it from there ;-)

Note You need to log in before you can comment on or make changes to this bug.