Bug 3466 - Bug while connecting USB-HDD
Bug while connecting USB-HDD
Status: REJECTED INVALID
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2004-09-26 09:55 UTC by Sacher Khoudari
Modified: 2006-03-06 10:25 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.8.1
Tree: Mainline
Regression: ---


Attachments

Description Sacher Khoudari 2004-09-26 09:55:48 UTC
Distribution: Debian Sarge
Hardware Environment: Athlon 1GHz, ASUS A7A266, 
Software Environment:
Problem Description: I just connected my USB-HDD (a 'TrekStor USB-Storage 2,5"')
to my USB-Hub (VIA USB-2.0 chip, ehci), and as I didn't hear the beeps from
usbmgr and couldn't detect it by scsidev I looked at dmesg and found the
following lines:

usb 5-2.4: new full speed USB device using address 14
usb 5-2.4: not running at top speed; connect to a high speed hub
kmem_cache_create: duplicate cache scsi_cmd_cache
------------[ cut here ]------------
kernel BUG at mm/slab.c:1382!
invalid operand: 0000 [#1]
PREEMPT 
Modules linked in: tun iptable_filter ip_tables sr_mod parport_pc lp parport ipv
6 vfat fat isofs dm_mod snd_virmidi snd_seq_virmidi snd_seq_midi snd_seq_oss snd
_seq_midi_event snd_seq ir_kbd_gpio ir_kbd_i2c ir_common tuner tvaudio msp3400 b
ttv video_buf i2c_algo_bit v4l2_common btcx_risc videodev loop usblp usb_storage
 mga w83781d i2c_sensor i2c_ali1535 i2c_core snd_ens1371 snd_rawmidi snd_seq_dev
ice snd_pcm_oss snd_mixer_oss snd_pcm snd_page_alloc snd_timer snd_ac97_codec sn
d soundcore gameport 8139too mii crc32 rtc
CPU:    0
EIP:    0060:[<c01428e4>]    Not tainted
EFLAGS: 00010202   (2.6.8.1) 
EIP is at kmem_cache_create+0x3e4/0x590
eax: 00000032   ebx: df7bfbd0   ecx: c050a24c   edx: c042a538
esi: c03fa8c0   edi: c03fa8c0   ebp: c1595d34   esp: c1595d00
ds: 007b   es: 007b   ss: 0068
Process khubd (pid: 24, threadinfo=c1594000 task=c1541100)
Stack: c03e1780 c03fa8b1 00000020 00002000 c1595d24 df7bfb1c ffffffff ffffffe0 
       df7bfae0 000000a0 c1575400 c047f9a0 c157540c c1595d60 c031d6f7 c03fa8b1 
       00000160 00000020 00002000 00000000 00000000 000001d8 c1575400 c15755d8 
Call Trace:
 [<c0105e2f>] show_stack+0x7f/0xa0
 [<c0105fc8>] show_registers+0x158/0x1b0
 [<c0106149>] die+0x89/0x100
 [<c0106533>] do_invalid_op+0xb3/0xc0
 [<c0105a99>] error_code+0x2d/0x38
 [<c031d6f7>] scsi_setup_command_freelist+0x87/0x120
 [<c031e794>] scsi_host_alloc+0x1b4/0x2c0
 [<e09a5949>] usb_stor_acquire_resources+0x89/0x130 [usb_storage]
 [<e09a5c71>] storage_probe+0x101/0x190 [usb_storage]
 [<c0333e74>] usb_probe_interface+0x54/0x60
 [<c02edd3d>] bus_match+0x3d/0x70
 [<c02eddb5>] device_attach+0x45/0xa0
 [<c02ee0b5>] bus_add_device+0x75/0xd0
 [<c02ecd8e>] device_add+0x9e/0x140
 [<c033b2b3>] usb_set_configuration+0x2b3/0x440
 [<c03362a9>] usb_new_device+0xa9/0x170
 [<c0336fb0>] hub_port_connect_change+0x230/0x410
 [<c033740f>] hub_events+0x27f/0x3d0
 [<c0337595>] hub_thread+0x35/0x110
 [<c01032b1>] kernel_thread_helper+0x5/0x14
Code: 0f 0b 66 05 3f 0f 3e c0 8b 0b e9 56 ff ff ff 8b 47 34 c7 04 


Steps to reproduce: Don't know, I bought the USB-HDD a just weak ago, but
connected and disconnected it a lot of times since then.
Comment 1 Alan Stern 2004-09-28 13:19:22 UTC
The information in this message probably didn't get back to the original poster:

http://marc.theaimsgroup.com/?l=linux-scsi&m=109638967308598&w=2

You might want to continue the discussion on the Linux Scsi
<linux-scsi@vger.kernel.org> mailing list.
Comment 2 Adrian Bunk 2006-01-08 02:33:48 UTC
Is this problem still present in kernel 2.6.15?
Comment 3 Greg Kroah-Hartman 2006-03-06 10:25:13 UTC
No response in 2 months, closing.  If this is still a problem, please reopen
with the requested information.

Note You need to log in before you can comment on or make changes to this bug.