Bug 3455 - compaq presario r3000 laptop hang on s3 resume
Summary: compaq presario r3000 laptop hang on s3 resume
Status: REJECTED INSUFFICIENT_DATA
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Venkatesh Pallipadi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-09-24 08:40 UTC by gad.kadosh
Modified: 2005-02-22 09:31 UTC (History)
0 users

See Also:
Kernel Version: 2.6.8.1
Tree: Mainline
Regression: ---


Attachments
dmesg from before the suspend, kernel 2.6.9 (8.85 KB, text/plain)
2004-11-09 11:02 UTC, gad.kadosh
Details
lsmod from before the suspend, kernel 2.6.9 (522 bytes, text/plain)
2004-11-09 11:04 UTC, gad.kadosh
Details
lspci + lspci -v + lspci -vv (19.31 KB, text/plain)
2004-11-09 11:26 UTC, gad.kadosh
Details

Description gad.kadosh 2004-09-24 08:40:51 UTC
Distribution: Gentoo
Hardware Environment: Compaq Presario R3000 laptop


Suspend-to-Ram seems to suspend correctly, the power button flashes like it
should be. To resume, I can use touchpad if psmouse is loaded when suspending,
or otherwise press a key on the keyboard. The power button is on again, the HD
spis up, the CD does too. but there's no display, and I believe the system is
totally hang, because i could not execute commands blindly, such as "find /",
that would show me HD usage.
I have tried with 2.6.8.1 and other vanilla kernels since 2.6.6 or even 2.6.5,
but with same results. I did test from single mode, with no modules loaded
except "unix". Also tried with and without APIC (which I use generally, though
not sure if I sould be).
Comment 1 Venkatesh Pallipadi 2004-11-08 14:49:37 UTC
Is the problem still there with latest 2.6 kernel?

If yes, can you make sure whether the problem is only with restore of the 
video (try connecting through network or serial after resume).

If it is only the video problem, 
- Please try the options in Documentation/power/video.txt
- Try the workaround in bug #3670

And also attach lspci acpidmp outputs here.
Comment 2 gad.kadosh 2004-11-09 11:01:45 UTC
I tried with kernel 2.6.9 and it's the same result. I believe it's not only a
video issue, but I'm not sure how to log into it from a remote machine, how can
I make sure it's connected after the resume? is it enough to connect it to the
network before suspending to assume the connection is kept after resuming?
In any case I tried from single mode. and I tried to issue commands like ls and
find to make the HD led light up, but it didn't seem to do anything. I also
tried Ctrl+Alt+Del and it doesn't do anything. I will attach dmesg and lsmod
from before the suspend. This laptop is the same one as the one from bug #3507
to which you responded (I still didn't succeed in overriding the BIOS SSDT), so
the DSDT and acpidmp should be the same.
Comment 3 gad.kadosh 2004-11-09 11:02:54 UTC
Created attachment 3997 [details]
dmesg from before the suspend, kernel 2.6.9
Comment 4 gad.kadosh 2004-11-09 11:04:05 UTC
Created attachment 3998 [details]
lsmod from before the suspend, kernel 2.6.9
Comment 5 Venkatesh Pallipadi 2004-11-09 11:14:16 UTC
Can you also attach lspci output.

You can do something like
echo 3 > /proc/acpi/sleep && cd / && find . -print
and check whether HD light turns on after resume.

Comment 6 gad.kadosh 2004-11-09 11:26:14 UTC
Created attachment 3999 [details]
lspci + lspci -v + lspci -vv
Comment 7 gad.kadosh 2004-11-09 11:36:55 UTC
I tried this command but the HD didn't seem to do anything. just total hang. in
the file I attached there's lspci, lspci -v, and lspci -vv- just in case :)
Comment 8 Venkatesh Pallipadi 2004-11-09 12:14:06 UTC
OK. You have Radeon video card. So, in future you may have issue with video 
and bug #3670 should help you then. But you have a different problem as of now.

Not sure where it is failing. You need to enable debug messahes (debug=1 in 
commandline) and add more of your own debug message and try to figure out 
whether the resume code is starting even. There are some beep code generating 
patch that you can use when video is not working.

bug #2664 seems to be similar one to this one.
Comment 9 Venkatesh Pallipadi 2005-02-22 09:31:10 UTC
There has been no update on this for 3 months. So, closing this one. Feel free 
to reopen this bug, if it is still a issue with latest kernels.

Note You need to log in before you can comment on or make changes to this bug.