Bug 34532 - Battery not detected
Battery not detected
Status: CLOSED DUPLICATE of bug 15707
Product: ACPI
Classification: Unclassified
Component: Power-Battery
All Linux
: P1 normal
Assigned To: Lan Tianyu
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-04 22:01 UTC by Otto Domínguez
Modified: 2011-05-24 02:06 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.38-8 ubuntu
Tree: Mainline
Regression: No


Attachments
dmesg (58.69 KB, text/plain)
2011-05-04 22:01 UTC, Otto Domínguez
Details
acpidump (259.13 KB, text/plain)
2011-05-04 22:01 UTC, Otto Domínguez
Details
acpidump (243.10 KB, application/octet-stream)
2011-05-16 17:09 UTC, Steve
Details
dmesg (30.52 KB, text/plain)
2011-05-22 23:02 UTC, RES
Details

Description Otto Domínguez 2011-05-04 22:01:16 UTC
Created attachment 56652 [details]
dmesg

Toshiba L645-SP4130L, Insyde H2O BIOS 2.30 (latest available).
Battery is not detected.
Comment 1 Otto Domínguez 2011-05-04 22:01:55 UTC
Created attachment 56662 [details]
acpidump
Comment 2 Steve 2011-05-16 17:00:10 UTC
Hi,
my Toshiba L645-S4060 also has this.
bios version 1.70

Using ubuntu 11.04

battery shows as not present, and ac-adapter plugged/unplugged never changes
in /proc/acpi/

My DSDT looks similar to Otto's

I changed my DSDT and compiled it into a custom kernel.

Originally ther was this line under the EC0 device:
OperationRegion (EMEM, SystemMemory, 0xFF808001, 0xFF)


I changed it to this:
OperationRegion (EMEM, EmbeddedControl, 0x00, 0xFF)

now battery status and ac adapter status seem to work perfectly.
-Steve
Comment 3 Steve 2011-05-16 17:09:37 UTC
Created attachment 58212 [details]
acpidump
Comment 4 RES 2011-05-22 23:01:07 UTC
No dsdt file present in /proc/acpi

Battery is not detected.

cat /proc/acpi/battery/BAT1/*
present:                 no
present:                 no
present:                 no

There is no BAT0.

uname -a
Linux erased 2.6.37.6 #3 SMP Sat Apr 9 22:49:32 CDT 2011 x86_64 Intel(R) Core(TM) i3 CPU M 380 @ 2.53GHz GenuineIntel GNU/Linux

This is on a toshiba satellite L645-S4104, new bios version 2.30. I've attached a copy of dmesg.
Comment 5 RES 2011-05-22 23:02:10 UTC
Created attachment 59032 [details]
dmesg
Comment 6 Zhang Rui 2011-05-23 01:28:06 UTC

*** This bug has been marked as a duplicate of bug 15707 ***
Comment 7 gmoutso 2011-05-23 11:53:32 UTC
What Steve did works for me on Satellite L600

Note You need to log in before you can comment on or make changes to this bug.