Bug 34262 - Enabling CONFIG_X86_X2APIC results in hard lock up on Intel i7-2820/QM67 platform
Enabling CONFIG_X86_X2APIC results in hard lock up on Intel i7-2820/QM67 plat...
Status: RESOLVED DUPLICATE of bug 43054
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 normal
Assigned To: platform_x86_64@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-03 04:39 UTC by Alex Dubov
Modified: 2012-08-23 13:50 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.38.4
Tree: Mainline
Regression: Yes


Attachments

Description Alex Dubov 2011-05-03 04:39:46 UTC
When CONFIG_X86_X2APIC is set, the machine in question (Lenovo W520) will lock up during early stages of system boot. Machine suddenly becomes completely unresponsive and no further diagnostics can be obtained.

Kernel boots correctly until root file system is mounted and udev starts its "settle" phase, loading the modules for pending uevents. There seems to be no correlation between the modules being loaded and the lock up event occurring, yet it always happens during this stage.

If X2APIC is disabled, everything works fine.

I marked this as regression as setting this option never used to cause me any trouble on other machines (including slightly older Xeon boxes).
Comment 1 Andrew Morton 2011-05-03 23:48:43 UTC
From which kernel version is this a regression?
Comment 2 Alex Dubov 2011-05-04 04:37:11 UTC
(In reply to comment #1)
> From which kernel version is this a regression?

Apparently it's not a regression, sorry.

Both machines I've thought to be a reference for this (with 2.6.37 and 2.6.37.2 kernels) have this option not set, even though I was sure they do.
Comment 3 hansbee 2012-04-06 00:44:42 UTC
See also Bug 43054
Comment 4 Alan 2012-08-23 13:50:01 UTC

*** This bug has been marked as a duplicate of bug 43054 ***

Note You need to log in before you can comment on or make changes to this bug.