Bug 34182 - Hard hang arising from TCP/IP related bug in 2.6.39-rc4
Hard hang arising from TCP/IP related bug in 2.6.39-rc4
Status: CLOSED CODE_FIX
Product: Networking
Classification: Unclassified
Component: IPV4
All Linux
: P1 blocking
Assigned To: Stephen Hemminger
:
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-05-01 17:32 UTC by Peter Teoh
Modified: 2011-05-14 21:47 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.39-rc4
Tree: Mainline
Regression: Yes


Attachments
kernel crash log via dmesg (5.33 KB, application/octet-stream)
2011-05-01 17:32 UTC, Peter Teoh
Details
2.6.39rc5 crashes again!!! (5.65 KB, application/octet-stream)
2011-05-05 13:48 UTC, Peter Teoh
Details
2nd version of crash... (122.15 KB, application/octet-stream)
2011-05-05 13:54 UTC, Peter Teoh
Details

Description Peter Teoh 2011-05-01 17:32:06 UTC
Created attachment 56082 [details]
kernel crash log via dmesg

I did a git-update of linus git tree on 27 Apr 2011, built the new kernel image.   Ever since using the new image, I have been *consistently* getting many crashes - especially whenever my google chrome is retoring all its previous session connection.   

Two crashes (entire system freezes) are shown in attachment.   Ever since I have revert to previous version - as booting up twice and consistently twice it will fail within a few minutes after Chrome is used.

v2.6.39-rc4-245-g4175242

Previously working version:   2.6.38-rc2+.   Did not test anything between 2.6.38-rc2+ and 2.6.39-rc3, and 2.6.39-rc3 failed for me in other ways as well.

(http://bugzilla.kernel.org/show_bug.cgi?id=33272)
Comment 1 Andrew Morton 2011-05-01 17:37:16 UTC
(switched to email.  Please respond via emailed reply-to-all, not via the
bugzilla web interface).

On Sun, 1 May 2011 17:32:07 GMT bugzilla-daemon@bugzilla.kernel.org wrote:

> https://bugzilla.kernel.org/show_bug.cgi?id=34182
> 
>            Summary: Hard hang arising from TCP/IP related bug in
>                     2.6.39-rc4
>            Product: Networking
>            Version: 2.5
>     Kernel Version: 2.6.39-rc4
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: blocking
>           Priority: P1
>          Component: IPV4
>         AssignedTo: shemminger@linux-foundation.org
>         ReportedBy: htmldeveloper@gmail.com
>         Regression: No
> 
> 
> Created an attachment (id=56082)
>  --> (https://bugzilla.kernel.org/attachment.cgi?id=56082)
> kernel crash log via dmesg
> 
> I did a git-update of linus git tree on 27 Apr 2011, built the new kernel
> image.   Ever since using the new image, I have been *consistently* getting
> many crashes - especially whenever my google chrome is retoring all its
> previous session connection.   
> 
> Two crashes (entire system freezes) are shown in attachment.   Ever since I
> have revert to previous version - as booting up twice and consistently twice it
> will fail within a few minutes after Chrome is used.
> 
> v2.6.39-rc4-245-g4175242
> 
> Previously working version:   2.6.38-rc2+.   Did not test anything between
> 2.6.38-rc2+ and 2.6.39-rc3, and 2.6.39-rc3 failed for me in other ways as well.
> 
> (http://bugzilla.kernel.org/show_bug.cgi?id=33272)
>
Comment 2 Peter Teoh 2011-05-05 13:48:47 UTC
Created attachment 56742 [details]
2.6.39rc5 crashes again!!!   

this is linus git tree:

git describe
v2.6.39-rc5-274-g609cfda

the version v2.6.38-rc2 worked with also no instability (except for one serious userspace bug:   totem will restart gdm when enlarged, or volume-changing etc, and thus resulting in total logout of current login desktop session).
Comment 3 Peter Teoh 2011-05-05 13:54:21 UTC
Created attachment 56752 [details]
2nd version of crash...

notice that from line 1559 onwards, the progression of the system towards total hang-up is a slow-progressing one (look at the timestamp increment)....I still can capture several traces of dmesg as the system deteriorate.    seemingly due to harddisk error ?   but is definitely not, as the system reboot into other version without error eg, v2.6.38-rc2).   i noticed that the crash seemingly is accelerated by starting up multiple concurrent session in chrome.....not sure.

version of crash:   v2.6.39-rc5 (linus git tree)

git describe
v2.6.39-rc5-274-g609cfda
Comment 4 Andrew Morton 2011-05-06 21:27:23 UTC
Please don't update this report via the bugzilla interface - the net developers don't use bugzilla.  PLease use reply-to-all to my email, as I requested.
Comment 5 Peter Teoh 2011-05-07 17:36:54 UTC
the latest v2.6.39-rc6+ looked good:   all previous poroblems all resoolvedl.

Note You need to log in before you can comment on or make changes to this bug.