Bug 3405 - shutdown -h now causes a reboot instead of shutdown
Summary: shutdown -h now causes a reboot instead of shutdown
Status: REJECTED DUPLICATE of bug 3669
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Off (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Alexey Starikovskiy
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-09-15 12:58 UTC by Peter Kerwien
Modified: 2004-11-17 17:34 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.9-rc1 and -rc2
Tree: Mainline
Regression: ---


Attachments
dmesg (11.54 KB, text/plain)
2004-09-20 12:19 UTC, Peter Kerwien
Details
dsdt (19.89 KB, application/octet-stream)
2004-09-20 12:19 UTC, Peter Kerwien
Details
Patch to DSDT (611 bytes, patch)
2004-09-21 10:14 UTC, Alexey Starikovskiy
Details | Diff

Description Peter Kerwien 2004-09-15 12:58:55 UTC
Distribution: Gentoo Linux 2004.2
Hardware Environment: HP nx7000
Software Environment:
Problem Description: When I compile a 2.6.9-rc1 or -rc2 kernel with
CONFIG_ACPI_BUTTON=y, 'shutdown -h now' does a reboot instead of a shutdown.
With all previous 2.6.x kernel versions I have tried, there has been no problem
with this ACPI option and shutdown.

Steps to reproduce:

1. Compile and install a 2.6.9-rc1 or -rc2 kernel with CONFIG_ACPI_BUTTON=y
2. Execute: shutdown -h now
Comment 1 Alexey Starikovskiy 2004-09-20 05:10:28 UTC
Could you please attach a dmesg and /proc/acpi/dsdt ? 
Comment 2 Peter Kerwien 2004-09-20 12:19:15 UTC
Created attachment 3683 [details]
dmesg

Here is my dmesg
Comment 3 Peter Kerwien 2004-09-20 12:19:59 UTC
Created attachment 3684 [details]
dsdt

Here is my /proc/acpi/dsdt
Comment 4 Michael Grigoriev 2004-09-21 09:20:12 UTC
I have the same problem with zt3000 (the sister model of nx7000).
It first started happening somewhere between 2.6.7-mm1 and 2.6.8.1-mm2.
On an interesting note, the problem only occurs when connected to AC - when
running on battery power shutdown works fine.
Comment 5 Peter Kerwien 2004-09-21 10:14:55 UTC
I can comfirm that the same thing happen with 2.6.9-rc2:

- On AC => reboot
- On battery => shutdown
Comment 6 Alexey Starikovskiy 2004-09-21 10:14:56 UTC
Created attachment 3692 [details]
Patch to DSDT

There is an error in your DSDT.
I doubt that this is the cause of the problem, but anyway, here is the patch to
get rid of that error.
Comment 7 Peter Kerwien 2004-09-21 11:36:17 UTC
This kind of patch was totally new for me, but I followed the instructions from:

http://forums.gentoo.org/viewtopic.php?t=122145

Booted my static DSDT override patched kernel, but 'shutdown -h now' still reboots.
Comment 8 Michael Grigoriev 2004-09-24 09:02:18 UTC
I too am pretty sure it's not the DSDT. I remember fixing mine a while back, but
it made no difference that I could notice, so I reverted it. Plus the problem is
quite clearly associated with specific kernel versions, so.... 

Another (very annoying) thing I noticed is that sometimes (1 in 3-4 maybe?) when
it does actually shutdown, it goes into a "bad" state, where it will no longer
turn on just by pressing the power button. I have to unplug it, remove the
battery, let it sit for while, and only then will it power on again.

Not sure if it might be caused by deffective hardware... Peter does that ever
happen to you?
Comment 9 Peter Kerwien 2004-09-24 09:14:27 UTC
No, everything has been rock solid. Until 2.6.9-rc1.
Comment 10 Steffen Viergutz 2004-10-06 10:22:46 UTC
Same Problem here with an NX7000 and the 2.6.9-rc3 kernel. No shutdown only a 
reboot instead.
With the Kernel 2.6.8.1 it works fine. 
Updatet yesterday to 2.6.9-rc3.

Best regards
Comment 11 Jukka Ketelaars 2004-10-18 05:03:59 UTC
I have the same problem with 2.6.9-rc4 on an nx7010. Otherwise the same as the 
rest of the reports: only happens when on AC, problem exists since rc1.
Comment 12 Alan Swanson 2004-10-23 23:44:29 UTC
I'm having the same problem with my laptop shutting down and immediately
switching back on. The (only) change to drivers/acpi/button.c in 2.6.9 (BK 1.25)
looks a wee bit suspicious as it dealing with wakeups.

I'd suggest commenting out the "if (device->wakeup.flags.valid)" statement and
see if it fixes the problem. I'll try later today when I finish work.

Comment 13 Alan Swanson 2004-10-24 01:12:50 UTC
Nope, still switches back on. Problem is elsewhere.
Comment 14 Sebastian Kannengiesser 2004-10-24 05:31:12 UTC
I'm having same troubles on nx7010 on 2.6.9-stable. As above stated, it only
occurs when running on AC, no matter whether the battery is inserted or not. I
switched a few days ago directly from 2.6.7 where the problem does not exist. I
will check for diffs in acpi code and hopefully me or someone else will find the
source of the problem as it is rather annoying not to be able to shut your
laptop properly down.
Comment 15 Georg Müller 2004-10-26 08:31:24 UTC
same problem on Acer TM 630 

It does not shut down w/ oder w/o AC - it reboots in either case.
It only shuts down with lid closed.

2.6.9 stable
Comment 16 Steffen Viergutz 2004-11-07 22:45:25 UTC
Tested again with Kernel 2.6.10-rc1 but problem still exists... No change for me :-(
Hope the problem will be fixed, because it's really annoying...

Best regards
Comment 17 Sérgio M Basto 2004-11-08 02:29:12 UTC
see if is not a duplicated bug of bug2109
http://bugme.osdl.org/show_bug.cgi?id=2109
Comment 18 Len Brown 2004-11-15 19:33:37 UTC
please try the patch in bug 3669 
Comment 19 Peter Kerwien 2004-11-17 07:45:34 UTC
I took the patch in bug 3669, and applied it to kernel 2.6.9. I cannot build the
kernel, unleass I also modify the Makefile in the drivers/acpi/sleep directory
so it also compiled wakeup.c (I don't know if this is due to that the patch i
tailored for another kernel version, or due to my kernel config or to some
errors in the patch). But when this kernel is installed, a 'shutdown -h now' now
works as before, i.e. my laptop i powered off properly.
Comment 20 Alan Swanson 2004-11-17 10:21:07 UTC
Confirm that with this patch my HP nx7010 now powers off correctly when running
on AC power (and checked that battery power continued to shutdown as normal).
Comment 21 Shaohua 2004-11-17 17:34:24 UTC

*** This bug has been marked as a duplicate of 3669 ***

Note You need to log in before you can comment on or make changes to this bug.