Bug 34012 - 2.6.39-rc4+: oom-killer busy killing tasks
2.6.39-rc4+: oom-killer busy killing tasks
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: XFS
All Linux
: P1 normal
Assigned To: XFS Guru
:
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-04-27 19:17 UTC by Maciej Rutecki
Modified: 2011-05-14 21:48 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.39-rc4+
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-04-27 19:17:23 UTC
Subject    : 2.6.39-rc4+: oom-killer busy killing tasks
Submitter  : Christian Kujau <lists@nerdbynature.de>
Date       : 2011-04-22 1:57
Message-ID : alpine.DEB.2.01.1104211841510.18728@trent.utfs.org
References : http://marc.info/?l=linux-kernel&m=130343744622331&w=2

This entry is being used for tracking a regression from 2.6.38. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Christian Kujau 2011-04-30 20:32:31 UTC
It was suggested to enable CONFIG_TREE_RCU, but this did not help:

  http://marc.info/?l=linux-kernel&m=130410712317606&w=2
  https://lkml.org/lkml/2011/4/25/124 (RCU free starvation thread)

Then it was suspected that it could be an old hrtimer bug and a patch was proposed, but it did not help either:

  http://marc.info/?l=linux-xfs&m=130412362601283&w=2

This issue is still present in 2.6.39-rc5-00091-gfafc992.
Comment 2 Christian Kujau 2011-05-06 10:09:13 UTC
Dave Chinner posted a patch that helps, it's not in mainline (yet):

   http://www.spinics.net/lists/xfs/msg04688.html
Comment 3 Florian Mickler 2011-05-09 09:31:18 UTC
Patch: http://www.spinics.net/lists/xfs/msg04688.html

Thanks for the update.
Comment 4 Rafael J. Wysocki 2011-05-14 21:48:50 UTC
Fixed by commit 228d62dd3f74734b9801c789b5addc57fdfc208f .

Note You need to log in before you can comment on or make changes to this bug.