Bug 34002 - [REGRESSION] [2.6.39-rc3] Wrong resolution in framebuffer and X Window
[REGRESSION] [2.6.39-rc3] Wrong resolution in framebuffer and X Window
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-04-27 19:11 UTC by Maciej Rutecki
Modified: 2011-06-23 21:10 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.39-rc3
Tree: Mainline
Regression: Yes


Attachments
dmesg from 2.6.38 (39.93 KB, text/plain)
2011-06-05 19:12 UTC, Maciej Rutecki
Details
Xorg.log from 2.6.38 (25.45 KB, text/x-log)
2011-06-05 19:13 UTC, Maciej Rutecki
Details

Description Maciej Rutecki 2011-04-27 19:11:16 UTC
Subject    : [REGRESSION] [2.6.39-rc3] Wrong resolution in framebuffer and X Window
Submitter  : Maciej Rutecki <maciej.rutecki@gmail.com>
Date       : 2011-04-17 16:04
Message-ID : 201104171804.04664.maciej.rutecki@gmail.com
References : http://marc.info/?l=linux-fbdev&m=130305625114863&w=2

This entry is being used for tracking a regression from 2.6.38. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Maciej Rutecki 2011-04-28 19:15:33 UTC
Still present in -rc5

Regards
Comment 2 Maciej Rutecki 2011-05-07 19:51:25 UTC
Still present in -rc6

Regards
Comment 3 Maciej Rutecki 2011-05-15 19:11:49 UTC
Still present in -rc7.
Comment 4 Maciej Rutecki 2011-05-19 19:01:26 UTC
Still unresolved and present in 2.6.39.
Comment 5 Maciej Rutecki 2011-06-05 14:33:52 UTC
Still cannot use kernel newer than 2.6.38. That any kernel (intel) developer can say how resolve this? This bug has been over a month, and still has the status of "new".
Comment 6 Chris Wilson 2011-06-05 14:58:59 UTC
Your monitor doesn't supply a valid EDID. Attach an Xorg.log+dmesg from a working kernel so that I can see why it might have been judged invalid.
Comment 7 Maciej Rutecki 2011-06-05 19:12:48 UTC
Created attachment 60872 [details]
dmesg from 2.6.38
Comment 8 Maciej Rutecki 2011-06-05 19:13:17 UTC
Created attachment 60882 [details]
Xorg.log from 2.6.38
Comment 9 Maciej Rutecki 2011-06-20 15:36:38 UTC
Result of bisection:
8f9a3f9b63b8cd3f03be9dc53533f90bd4120e5f is the first bad commit
commit 8f9a3f9b63b8cd3f03be9dc53533f90bd4120e5f
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Tue Feb 1 09:01:13 2011 +0000

    drm/i915: Enable GMBUS for post-gen2 chipsets
    
    With the recent SDVO fix, this is working on all the machines I have to
    hand - except for an 845G.
    
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>

:040000 040000 eb835ca9bf353d1d548b69d415801720a577184a 3e0a9430c43030735dfe2f694a1ad694cc01d483 M      drivers

Revert this commit from 3.0-rc1 solves problem.
Comment 10 Maciej Rutecki 2011-06-23 17:36:00 UTC
Tested 3.0-rc4 (changelog shows that this commit has been reverted): work fine. Close bug.
Comment 11 Florian Mickler 2011-06-23 21:10:14 UTC
Nice.

Note You need to log in before you can comment on or make changes to this bug.