Bug 33912 - [RV515] Kernel .35 onwards, Random X freezes while scrolling
Summary: [RV515] Kernel .35 onwards, Random X freezes while scrolling
Status: RESOLVED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: All Linux
: P1 high
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-25 09:31 UTC by Vish
Modified: 2012-08-20 15:53 UTC (History)
2 users (show)

See Also:
Kernel Version: .35, .36, .37, .38, .39
Tree: Mainline
Regression: Yes


Attachments
gdb of X using Kernel 2.6.38-02063802 (10.13 KB, text/plain)
2011-04-25 09:31 UTC, Vish
Details
gdb of X using Kernel 2.6.35-1(ubuntu) (10.13 KB, text/plain)
2011-04-25 09:33 UTC, Vish
Details
gdb of X using Kernel 2.6.35-020635rc1 (10.14 KB, text/plain)
2011-04-25 09:35 UTC, Vish
Details
Xorg.0.log (37.23 KB, text/plain)
2011-04-25 09:37 UTC, Vish
Details
dmesg (58.99 KB, text/plain)
2011-04-27 20:21 UTC, Vish
Details
kern.log (315.27 KB, text/plain)
2011-04-27 20:24 UTC, Vish
Details
syslog (197.23 KB, text/plain)
2011-04-27 20:25 UTC, Vish
Details
Syslog-e (195.50 KB, text/plain)
2011-04-29 09:25 UTC, Vish
Details

Description Vish 2011-04-25 09:31:52 UTC
Created attachment 55352 [details]
gdb of X using Kernel 2.6.38-02063802

From kernel .35 onwards the system freezes at random.
This is mostly while scrolling scrolling pages while they load in Firefox(most common) or while scrolling in Nautilus/Gedit windows while they load.

Once it freezes I'm not able to do anything, only the mouse pointer alone moves but nothing else responds. It seems to happen when there is increased disk read/write.(but I'm not very sure of this) I'm using btrfs for my /home partition.

This regression starts in Kernel 2.6.35-1-generic #1-Ubuntu SMP Sat Jun 5 06:18:25 UTC 2010 i686 GNU/Linux

While, I dont have any problems with Kernel 2.6.34-5-generic #14-Ubuntu SMP Fri Jun 4 06:18:40 UTC 2010 i686 GNU/Linux or MainlineKernel 2.6.34-02063407-generic #201009140905 SMP Tue Sep 14 10:10:14 UTC 2010 i686 GNU/Linux, both work fine.

Problem is also present in Mainline Kernel 2.6.36-020636 , Ubuntu Kernel 2.6.37-12.26 , Mainline Kernel 2.6.37-020637rc8 , Ubuntu Kernel 2.6.38-1 and Mainline Kernel 2.6.38-02063802

I'm not able to test with kernel .39 because I'm having network issues with that.

=====

Lspci : https://launchpadlibrarian.net/66142452/Lspci.txt
glxinfo : https://launchpadlibrarian.net/66142464/glxinfo.txt
PciDisplay : https://launchpadlibrarian.net/66142454/PciDisplay.txt

Other Hardware info: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/733392

=====

------------------ProblemType: BugDistroRelease: Ubuntu 10.10
Package: xorg 1:7.5+6ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-6.7-generic 2.6.35-rc3
Uname: Linux 2.6.35-6-generic i686
Architecture: i386
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800 1280x720 1152x768 1024x768 800x600 848x480 720x480 640x480
 edid-base64: AP///////wBEk0EAAAAAAAAPAQOAIRV4Ck3Ak1xRiCchUFQAAAABAQEBAQEBAQEBAQEBAQEB6hoAgFAgEDAVIEQAS88QAAAYAAAADwAIACoAAQAEADJKBBkBAAAA/gBRVUFOVEFESVNQTEFZAAAA/gBRRDE1VEwwNzIKICAgAIk=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
Date: Fri Mar 11 22:38:14 2011InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100924)
MachineType: Acer, inc. Aspire 5670
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-6-generic root=UUID=d0b3b834-dc68-4ad5-95e1-afefebd792ea ro quiet splash
ProcEnviron:
 LANG=en_IN
 SHELL=/bin/bashSourcePackage: xorg
dmi.bios.date: 01/12/07
dmi.bios.vendor: Acer
dmi.bios.version: v1.3239
dmi.board.name: Bodensee
dmi.board.vendor: Acer, Inc.
dmi.board.version: Not Applicable
dmi.chassis.type: 1
dmi.chassis.vendor: Acer, Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvrv1.3239:bd01/12/07:svnAcer,inc.:pnAspire5670:pvrNotApplicable:rvnAcer,Inc.:rnBodensee:rvrNotApplicable:cvnAcer,Inc.:ct1:cvrN/A:
dmi.product.name: Aspire 5670
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer, inc.system: distro: Ubuntu codename: maverick
 architecture: i686
 kernel: 2.6.35-6-generic
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: vishnoo 10075 F.... pulseaudio
 /dev/snd/pcmC0D0p: vishnoo 10075 F...m pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xc8000000 irq 47'
   Mixer name : 'Realtek ALC883'
   Components : 'HDA:10ec0883,1025160d,00100002 HDA:14f12bfa,10250094,00090000'   Controls : 21   Simple ctrls : 12DistroRelease: Ubuntu 10.10
Frequency: I don't know.
HibernationDevice: RESUME=UUID=87513ef2-a303-4082-94f3-352058dbd5eeInstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100924)
MachineType: Acer, inc. Aspire 5670
Package: linux (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-6-generic root=UUID=d0b3b834-dc68-4ad5-95e1-afefebd792ea ro quiet splash
ProcEnviron:
 LANG=en_IN
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-6.7-generic 2.6.35-rc3Regression: Yes
RelatedPackageVersions: linux-firmware 1.38.4
Reproducible: No
RfKill:
 0: phy0: Wireless LAN  Soft blocked: no  Hard blocked: noTags: maverick kernel-graphics regression-release
Comment 1 Vish 2011-04-25 09:33:39 UTC
Created attachment 55362 [details]
gdb of X using Kernel 2.6.35-1(ubuntu)
Comment 2 Vish 2011-04-25 09:35:12 UTC
Created attachment 55372 [details]
gdb of X using Kernel 2.6.35-020635rc1
Comment 3 Vish 2011-04-25 09:37:04 UTC
Created attachment 55382 [details]
Xorg.0.log
Comment 4 Vish 2011-04-27 20:21:36 UTC
Created attachment 55621 [details]
dmesg

It froze again(Apr 27 20:42:06) with same gdb, did a 
$ echo t > /proc/sysrq-trigger
And then SAK to restart session. Attaching the dmesg
Comment 5 Vish 2011-04-27 20:24:10 UTC
Created attachment 55631 [details]
kern.log

kern.log Contains today's freeze, Apr 27 20:42:06 , and the previous one Apr 25 01:45:20
Comment 6 Vish 2011-04-27 20:25:14 UTC
Created attachment 55641 [details]
syslog
Comment 7 Vish 2011-04-29 09:25:51 UTC
Created attachment 55882 [details]
Syslog-e

Attaching the syslog when X froze while scrolling in evince
Comment 8 Vish 2011-06-10 03:22:57 UTC
Also happens in .39 kernel
$ uname -a
Linux Aspire-5670 2.6.39-02063901-generic #201106030905 SMP Fri Jun 3 10:56:14 UTC 2011 i686 GNU/Linux
Comment 9 Alex Deucher 2011-06-10 05:05:08 UTC
Can you bisect?
Comment 10 Vish 2011-06-10 07:50:02 UTC
(In reply to comment #9)
> Can you bisect?

I have never bisected a kernel, but I can try. Just have a few doubts.

1 * Can I do with the Ubuntu kernel as per Ubuntu instructions[0] as:
$ git bisect start Ubuntu-2.6.35-1.1 Ubuntu-2.6.34-5.14

Which seems a saner incremental interval of Jun5 -> Jun 4.

Whereas Mainline Kernel 2.6.35-020635rc1-generic #020635rc1[1] which is dated Jun 1 had the problem , but Kernel 2.6.34-02063407-generic #201009140905[2] dated Sep 14(!!!) did not have the problem.

2 * Are there any pointers to narrow down the kernel commit from the backtraces I have posted?
Or is just looking for "drivers/gpu/drm/radeon/" the closest?

3 * Is there any specific command I need to run if I hit the bug? 
Or is gdb of X sufficient? 
Do I need to set any variables to get better logs of the freeze?
(This is a very random bug which can sometimes take days, would be nice to know just to be prepared. And I dont know much about kernel, hence the Qs.. :D )


[0]<https://wiki.ubuntu.com/Kernel/KernelBisection>
[1]<http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.35-rc1-lucid/>
[2]<http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.34.7-maverick/> 
[3]<http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-maverick.git;a=commit;h=67a3e12b05e055c0415c556a315a3d3eb637e29e>
Comment 11 Alex Deucher 2011-06-10 15:10:39 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > Can you bisect?
> 
> I have never bisected a kernel, but I can try. Just have a few doubts.
> 
> 1 * Can I do with the Ubuntu kernel as per Ubuntu instructions[0] as:
> $ git bisect start Ubuntu-2.6.35-1.1 Ubuntu-2.6.34-5.14
> 
> Which seems a saner incremental interval of Jun5 -> Jun 4.

That should be fine.  The closest two kernels that where which have and don't have the problem are your best bet.

> 2 * Are there any pointers to narrow down the kernel commit from the
> backtraces
> I have posted?
> Or is just looking for "drivers/gpu/drm/radeon/" the closest?

You can narrow the bisection to just radeon, but if the problem is something non-radeon you'll get inconclusive results.

> 
> 3 * Is there any specific command I need to run if I hit the bug? 
> Or is gdb of X sufficient? 
> Do I need to set any variables to get better logs of the freeze?

It's really hard to narrow down what causes the GPU to hang.  It could be a bug in the kernel, it could also be a certain combination of command buffers or userspace acceleration drivers that happen to make the GPU angry.  Just getting the commit id should be enough.  You might also try a newer ddx and/or mesa 3D driver to see if that helps.
Comment 12 Vish 2011-06-10 16:55:13 UTC
(In reply to comment #11)
> Just getting the commit id should be enough. 

OK, sure will try that.

Note You need to log in before you can comment on or make changes to this bug.