Bug 33792 - lockdep trace when unplugging usb audio (.39rc4)
lockdep trace when unplugging usb audio (.39rc4)
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA)
All Linux
: P1 normal
Assigned To: Jaroslav Kysela
:
Depends on:
Blocks: 27352
  Show dependency treegraph
 
Reported: 2011-04-21 17:30 UTC by Maciej Rutecki
Modified: 2013-11-13 17:31 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.39-rc4
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-04-21 17:30:43 UTC
Subject    : lockdep trace when unplugging usb audio (.39rc4)
Submitter  : Dave Jones <davej@redhat.com>
Date       : 2011-04-19 18:07
Message-ID : 20110419180745.GA438@redhat.com
References : http://marc.info/?l=linux-kernel&m=130323648920431&w=2

This entry is being used for tracking a regression from 2.6.38. Please don't
close it until the problem is fixed in the mainline.
Comment 1 James Hogan 2011-05-12 21:46:36 UTC
I see this when suspending my laptop in 2.6.39-rc7. I've seen these warnings since 2.6.39-rc2 (didn't try rc1), although I can't remember if exactly the same warning. Don't see any warnings in 2.6.38.

Is it worth me spending the time to try and bisect it, or is the problem obvious from the log?
Comment 2 James Hogan 2011-05-15 07:04:06 UTC
I just saw this exact same circular locking warning on v2.6.38
Comment 3 Rafael J. Wysocki 2011-05-15 09:16:25 UTC
OK, suppose it's a post-2.6.37 regression.
Comment 4 Takashi Iwai 2013-11-13 17:31:36 UTC
The race must have been already fixed in the upstream.

Note You need to log in before you can comment on or make changes to this bug.