Bug 33582 - unable to hibernate with nouveau and NV11 [bisected]
unable to hibernate with nouveau and NV11 [bisected]
Status: RESOLVED OBSOLETE
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks: 16444
  Show dependency treegraph
 
Reported: 2011-04-18 16:21 UTC by C Sights
Modified: 2013-12-23 12:08 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.
Tree: Mainline
Regression: Yes


Attachments

Description C Sights 2011-04-18 16:21:11 UTC
Hi,
   I'm able to successfully hibernate while using nouveau with kernel version 2.6.35 (and before) but unable to hibernate in 2.6.36 (and after up to 2.6.39-rc$YESTERDAY).
   I am not using X.  From the console I test whether hibernate is possible using "pm-hibernate".
   I've bisected this and located a range of possible commits which changed this behavior.  
last known good: d17f395cdcec39033a481f96d75e8b3d3c41d43a
first known bad: 816544b21b020bdb9dcb9a5003fe3e1f109e8698
   Between these commits the kernel would not compile.


   This is the nVidia card in the machine.
02:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2) (prog-if 00 [VGA controller])
        Subsystem: nVidia Corporation Device 0054
        Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 11
        Memory at dc000000 (32-bit, non-prefetchable) [size=16M]
        Memory at d0000000 (32-bit, prefetchable) [size=128M]
        [virtual] Expansion ROM at dd000000 [disabled] [size=64K]
        Capabilities: [60] Power Management version 2
        Capabilities: [44] AGP version 2.0

Let me know if I can provide more info or test patches!

Thanks,  Chad.
Comment 1 C Sights 2011-04-30 17:03:51 UTC
bug is being acted on here:
https://bugs.freedesktop.org/show_bug.cgi?id=36422
Will update if this bug is closed.

But FYI, the first bad commit is:

190a43783f2c43186180c827444d4eac901b4bcf is the first bad commit
commit 190a43783f2c43186180c827444d4eac901b4bcf
Author: Francisco Jerez <currojerez@riseup.net>
Date:   Thu Jun 17 12:42:14 2010 +0200

    drm/nouveau: Don't clear AGPCMD completely on INIT_RESET.

    We just need to clear the SBA and ENABLE bits to reset the AGP
    controller: If the AGP bridge was configured to use "fast writes",
    clearing the FW bit would break the subsequent MMIO writes and
    eventually end with a lockup.

    Note that all the BIOSes I've seen do the same as we did (it works for
    them because they don't use MMIO), OTOH the blob leaves FW untouched.

    Signed-off-by: Francisco Jerez <currojerez@riseup.net>
    Signed-off-by: Ben Skeggs <bskeggs@redhat.com>

:040000 040000 2af374ca41a86c67a662fd99fa0516df54ef3c55
89468256a014ee395b57d2ae2e1277fd8c244f31 M  drivers

Note You need to log in before you can comment on or make changes to this bug.