Bug 33462 - [BUG 2.6.39-rc3] NFS spinlock recursion
[BUG 2.6.39-rc3] NFS spinlock recursion
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: NFS
All Linux
: P1 normal
Assigned To: Trond Myklebust
:
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-04-17 18:19 UTC by Maciej Rutecki
Modified: 2011-04-18 00:05 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.39-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-04-17 18:19:26 UTC
Subject    : [BUG 2.6.39-rc3] NFS spinlock recursion
Submitter  : Wu Fengguang <fengguang.wu@intel.com>
Date       : 2011-04-15 2:47
Message-ID : 20110415024758.GA20420@localhost
References : http://marc.info/?l=linux-kernel&m=130283572008367&w=2

This entry is being used for tracking a regression from 2.6.38. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Trond Myklebust 2011-04-18 00:05:09 UTC
Was already fixed in mainline at the time the bug report was filed. Please
see commit 0d88f6e804c824454b5ed0d3034ed3dcf7467a87 (nfs: don't call
__mark_inode_dirty while holding i_lock).
Comment 2 Trond Myklebust 2011-04-18 00:05:36 UTC
Please reopen if the bug occurs again.

Note You need to log in before you can comment on or make changes to this bug.