Bug 33452 - [Regression,bisected] 2.6.39-rc3 ceph client write hangs
[Regression,bisected] 2.6.39-rc3 ceph client write hangs
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: fs_other
:
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-04-17 18:16 UTC by Maciej Rutecki
Modified: 2011-04-18 14:06 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.39-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-04-17 18:16:39 UTC
Subject    : [Regression,bisected] 2.6.39-rc3 ceph client write hangs
Submitter  : "Jim Schutt" <jaschut@sandia.gov>
Date       : 2011-04-15 17:00
Message-ID : 4DA879CA.8060305@sandia.gov
References : http://marc.info/?l=linux-kernel&m=130288689327560&w=2

This entry is being used for tracking a regression from 2.6.38. Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 250df6ed274d767da844a5d9f05720b804240197
Author: Dave Chinner <dchinner@redhat.com>
Date:   Tue Mar 22 22:23:36 2011 +1100

     fs: protect inode->i_state with inode->i_lock

First-Bad-Commit : 250df6ed274d767da844a5d9f05720b804240197
Comment 1 Maciej Rutecki 2011-04-18 14:05:02 UTC
Fixed by 283a85dc6e670083adb1e5437bd93d163f4f801a

Note You need to log in before you can comment on or make changes to this bug.