Bug 33432 - WARNING at libata-core.c:5015 in 2.6.39-rc3-wl+, then lockup.
WARNING at libata-core.c:5015 in 2.6.39-rc3-wl+, then lockup.
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA
All Linux
: P1 normal
Assigned To: Jeff Garzik
:
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-04-17 17:37 UTC by Maciej Rutecki
Modified: 2011-05-14 22:06 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.39-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-04-17 17:37:13 UTC
Subject    : WARNING at libata-core.c:5015 in 2.6.39-rc3-wl+, then lockup.
Submitter  : Ben Greear <greearb@candelatech.com>
Date       : 2011-04-13 16:29
Message-ID : 4DA5CF81.4070908@candelatech.com
References : http://marc.info/?l=linux-kernel&m=130271220809443&w=2

This entry is being used for tracking a regression from 2.6.38. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Ben Greear 2011-05-04 23:30:43 UTC
Root cause appears to be the slub cmpxcg issue recently fixed in
2.6.39-rc6+.  I was compiling my kernel for 586, so was susceptible,
even though processor was much more recent (Atom).

Please feel free to close this bug.

Note You need to log in before you can comment on or make changes to this bug.