Bug 33342 - [2.6.39-rc2][bisected] Constant DISK_MEDIA_CHANGE_EVENTS from CDROM drive.
[2.6.39-rc2][bisected] Constant DISK_MEDIA_CHANGE_EVENTS from CDROM drive.
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: IDE
All Linux
: P1 normal
Assigned To: io_ide@kernel-bugs.osdl.org
:
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-04-15 17:13 UTC by Maciej Rutecki
Modified: 2011-04-30 19:28 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.39-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-04-15 17:13:00 UTC
Subject    : [2.6.39-rc2][bisected] Constant DISK_MEDIA_CHANGE_EVENTS from CDROM drive.
Submitter  : Shaun Ruffell <sruffell@digium.com>
Date       : 2011-04-08 20:15
Message-ID : 20110408201513.GA3040@digium.com
References : http://marc.info/?l=linux-kernel&m=130229371907209&w=2

This entry is being used for tracking a regression from 2.6.38. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Shaun Ruffell 2011-04-18 04:13:48 UTC
I believe that this issue and #33412 are related.
Comment 2 Tejun Heo 2011-04-21 17:15:15 UTC
FYI, patches to address the issue have been posted.

  http://thread.gmane.org/gmane.linux.ide/49369

Thanks.
Comment 3 Shaun Ruffell 2011-04-21 17:58:53 UTC
These patches resolve the issue that I originally saw.
Comment 4 Rafael J. Wysocki 2011-04-30 19:27:34 UTC
Fixed by commits:
7c88a16 (block: don't propagate unlisted DISK_EVENTs to userland)
facc31d (block: Don't implicitly trigger event check on disk_unblock_events()).

Note You need to log in before you can comment on or make changes to this bug.