Bug 33252 - [regression 2.6.39-rc2][bisected] "perf, x86: P4 PMU - Read proper MSR register to catch" and NMIs
[regression 2.6.39-rc2][bisected] "perf, x86: P4 PMU - Read proper MSR regist...
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: platform_i386
:
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-04-13 19:32 UTC by Maciej Rutecki
Modified: 2011-04-30 19:18 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.39-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-04-13 19:32:39 UTC
Subject    : [regression 2.6.39-rc2][bisected] "perf, x86: P4 PMU - Read proper MSR register to catch" and NMIs
Submitter  : Shaun Ruffell <sruffell@digium.com>
Date       : 2011-04-06 22:30
Message-ID : 20110406223036.GA15721@digium.com
References : http://marc.info/?l=linux-kernel&m=130212907032580&w=2

This entry is being used for tracking a regression from 2.6.38. Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 242214f9c1eeaae40eca11e3b4d37bfce960a7cd
Author: Don Zickus <dzickus@redhat.com>
Date:   Thu Mar 24 23:36:25 2011 +0300

    perf, x86: P4 PMU - Read proper MSR register to catch unflagged overflows
    
    Signed-off-by: Don Zickus <dzickus@redhat.com>
    Signed-off-by: Cyrill Gorcunov <gorcunov@openvz.org>
    Cc: Lin Ming <ming.m.lin@intel.com>
    LKML-Reference: <4D8BAB49.3080701@openvz.org>
    Signed-off-by: Ingo Molnar <mingo@elte.hu>

First-Bad-Commit : 242214f9c1eeaae40eca11e3b4d37bfce960a7cd
Comment 1 Shaun Ruffell 2011-04-13 19:55:02 UTC
Just a note, the patch that Don Zickus prepared, which Cyrill attached to 
http://article.gmane.org/gmane.linux.kernel/1125621 resolved this issue for me.  I'll comment again when I've used a straight checkout of mainline that has this fix in it.

Thanks.
Comment 2 Rafael J. Wysocki 2011-04-17 12:45:31 UTC
Patch : http://cache.gmane.org//gmane/linux/kernel/1125621-001.bin
Handled-By : Don Zickus <dzickus@redhat.com>
Comment 3 Shaun Ruffell 2011-04-18 04:25:22 UTC
The patch that was originally tested caused problems with perf on another processor and still needs another revision.  That report was originally made at http://article.gmane.org/gmane.linux.kernel/1126590.
Comment 4 Shaun Ruffell 2011-04-19 15:47:20 UTC
Current patch for this was posted at: http://article.gmane.org/gmane.linux.kernel/1128149
Comment 5 Rafael J. Wysocki 2011-04-30 19:18:33 UTC
Fixed by commit 2bce5da (perf, x86, nmi: Move LVT un-masking into irq handlers).

Note You need to log in before you can comment on or make changes to this bug.